aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2016-01-15 16:02:29 +0100
committerAndreas Enge <andreas@enge.fr>2016-02-16 17:11:28 +0100
commit9bd9486df4680fe3eb39d8f7c98a77fab88ff307 (patch)
treeb4f4ce714b7cdc6c80b055a96306725f5c96512e /gnu/packages
parent6b5eb8406c0bba1032bc990efc9d63442a09a042 (diff)
downloadguix-9bd9486df4680fe3eb39d8f7c98a77fab88ff307.tar
guix-9bd9486df4680fe3eb39d8f7c98a77fab88ff307.tar.gz
gnu: pari-gp: Build documentation.
* gnu/packages/algebra.scm (pari-gp)[native-inputs]: Add texlive-minimal. [arguments]: Modify make-flags to build documentation.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/algebra.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 0f17403868..85ec61c1b1 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -26,6 +26,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages readline)
#:use-module (gnu packages flex)
+ #:use-module (gnu packages texlive)
#:use-module (gnu packages xorg)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -125,12 +126,13 @@ solve the shortest vector problem.")
(base32
"0c8l83a0gjq73r9hndsrzkypwxvnnm4pxkkzbg6jm95m80nzwh11"))))
(build-system gnu-build-system)
+ (native-inputs `(("texlive" ,texlive-minimal)))
(inputs `(("gmp" ,gmp)
("libx11" ,libx11)
("perl" ,perl)
("readline" ,readline)))
(arguments
- '(#:make-flags '("gp")
+ '(#:make-flags '("all")
;; FIXME: building the documentation requires tex; once this is
;; available, replace "gp" by "all"
#:test-target "dobench"