aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 22:22:27 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:07 -0400
commit81db76247cb105768b01bbbf42696ff76a27ac00 (patch)
treead587258b344f7dffe233db80ef09df87107ee16 /gnu/packages
parentd33297e7d6ce99bbc828d0b0a07a6e2221a18973 (diff)
downloadguix-81db76247cb105768b01bbbf42696ff76a27ac00.tar
guix-81db76247cb105768b01bbbf42696ff76a27ac00.tar.gz
gnu: Remove python2-ipaddr.
* gnu/packages/python-xyz.scm (python2-ipaddr): Delete variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 445b5cd02b..967aa2b410 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12824,34 +12824,6 @@ codecs (e.g. BER, PER, UPER, XER) as well as limited C source code generating
for OER and UPER.")
(license license:expat)))
-(define-public python2-ipaddr
- (package
- (name "python2-ipaddr")
- (version "2.1.11")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "ipaddr" version))
- (sha256
- (base32 "1dwq3ngsapjc93fw61rp17fvzggmab5x1drjzvd4y4q0i255nm8v"))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2 ;version 2 only
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _ (invoke "python" "ipaddr_test.py"))))))
- (home-page "https://github.com/google/ipaddr-py")
- (synopsis "IP address manipulation library")
- (description
- "Ipaddr is a Python@tie{}2 library for creating and manupilating IPv4 and
-IPv6 addresses and networks.
-
-For new implementations you may prefer to use the standard module
-@code{ipaddress}, which was introduced in Python 3.3 and backported to older
-versions of Python.")
- (license license:asl2.0)))
-
(define-public python-idna
(package
(name "python-idna")