aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2017-02-14 18:26:41 +0000
committerKei Kebreau <kei@openmailbox.org>2017-03-01 13:16:31 -0500
commit3a263368dd658ca5dc81e171ef041712c9e9b7a4 (patch)
tree5d7a43f365e6eb05a84e6574c12f805f3d085165 /gnu/packages
parent0da8313c679f101c3f99970c50d6f0fef995f633 (diff)
downloadguix-3a263368dd658ca5dc81e171ef041712c9e9b7a4.tar
guix-3a263368dd658ca5dc81e171ef041712c9e9b7a4.tar.gz
gnu: Add blists.
* gnu/packages/mail.scm (blists): New variable. Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/mail.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index f4f732ec19..a6cef7ab8d 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1951,3 +1951,38 @@ installation on systems where resources are limited. Its features include:
@item Rich and customisable texts for automated operations.
@end enumerate\n")
(license license:expat)))
+
+(define-public blists
+ (package
+ (name "blists")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.openwall.net/pub/projects/"
+ "blists/blists-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1gp51kmb8yv8d693wcpdslmwlbw5w2kgz4kxhrcaf7y89w8wy4qd"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; No tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "bindex" bin)
+ (install-file "bit" bin)
+ #t))))))
+ (home-page "http://www.openwall.com/blists/")
+ (synopsis "Web interface to mailing list archives")
+ (description
+ "Blists is a web interface to mailing list archives that works off
+indexed mbox files. There are two programs: @code{bindex} and @code{bit}.
+@code{bindex} generates or updates the index file (incremental updates
+are supported). @code{bit} is a CGI/SSI program that generates web pages
+on the fly. Both programs are written in C and are very fast.")
+ (license license:expat)))