aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-06-18 20:27:27 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-22 10:51:22 +0200
commit17972082ccb05cce550bc095d23bd6dcaf3ec5a7 (patch)
tree03853d040f47fa30881378784858fc4c8d144f10 /gnu/packages
parent61a9ba398f39258e603ba7eaf107ecf051d4f462 (diff)
downloadguix-17972082ccb05cce550bc095d23bd6dcaf3ec5a7.tar
guix-17972082ccb05cce550bc095d23bd6dcaf3ec5a7.tar.gz
gnu: Add gopkg.in/yaml.v3.
* gnu/packages/golang.scm (go-gopkg-in-yml-v3): New variable Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8c3c81ceda..1d17f02cdd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@mgail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2413,6 +2414,32 @@ which satisfies the cron expression.")
values.")
(license license:asl2.0)))
+(define-public go-gopkg-in-yaml-v3
+ (package
+ (name "go-gopkg-in-yaml-v3")
+ (version "3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gopkg.in/yaml.v3")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06f4lnrp494wqaygv09dggr2dwf3z2bawqhnlnnwiamg5y787k4g"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "gopkg.in/yaml.v3"))
+ (native-inputs
+ `(("go-gopkg-in-check-v1" ,go-gopkg-in-check-v1)))
+ (home-page "https://gopkg.in/yaml.v3")
+ (synopsis "YAML reader and writer for the Go language")
+ (description
+ "This package provides a Go library for encode and decode YAML values.
+The yaml package supports most of YAML 1.2, but preserves some behavior from
+1.1 for backwards compatibility.")
+ (license license:asl2.0)))
+
(define-public go-github-com-mattn-go-isatty
(package
(name "go-github-com-mattn-go-isatty")