aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-15 17:44:22 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-15 23:27:59 +0100
commit11e1df56e29e8e9f9dbe1beaf6afb902c33c9198 (patch)
treed4a5208b89c90f8eb70bce32a47316c048630612 /gnu/packages
parentee71d44e60a128e107436e1e0405b45280cb49c6 (diff)
downloadguix-11e1df56e29e8e9f9dbe1beaf6afb902c33c9198.tar
guix-11e1df56e29e8e9f9dbe1beaf6afb902c33c9198.tar.gz
gnu: gnome-shell: Remove references to Inkscape and more.
The reference to Inkscape was introduced in commit 45fef894eb5b39029633cd0cd907e8ce8c5ab379. * gnu/packages/gnome.scm (gnome-shell)[arguments]: Add #:disallowed-references and #:modules. Replace the 'glib-or-gtk-wrap' phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm21
1 files changed, 19 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8b473c231e..e3f470fcee 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5690,7 +5690,15 @@ properties, screen resolution, and other GNOME parameters.")
#t))))
(build-system glib-or-gtk-build-system)
(arguments
- '(#:phases
+ `(#:disallowed-references ((,glib "bin")
+ ,inkscape ,libxslt
+ ,ruby-sass)
+
+ #:modules ((guix build glib-or-gtk-build-system)
+ (guix build utils)
+ (srfi srfi-1))
+
+ #:phases
(modify-phases %standard-phases
(add-before 'build 'rebuild-css
(lambda _
@@ -5726,7 +5734,16 @@ properties, screen resolution, and other GNOME parameters.")
`("PYTHONPATH" ":" prefix (,python-path))
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
'("gnome-shell-extension-tool" "gnome-shell-perf-tool"))
- #t))))))
+ #t)))
+ (replace 'glib-or-gtk-wrap
+ (let ((wrap (assoc-ref %standard-phases 'glib-or-gtk-wrap)))
+ (lambda* (#:key inputs outputs #:allow-other-keys #:rest rest)
+ ;; By default Inkscape et al. would end up in the XDG_DATA_DIRS
+ ;; settings of the wrappers created by the 'glib-or-gtk-wrap'
+ ;; phase. Fix that since we don't need these.
+ (wrap #:inputs (fold alist-delete inputs
+ '("inkscape" "intltool" "glib:bin"))
+ #:outputs outputs)))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
("gobject-introspection" ,gobject-introspection)