aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-04-01 22:58:20 -0400
committerMark H Weaver <mhw@netris.org>2014-04-02 01:55:40 -0400
commit0d55c3563c963f457cc67a728b937a67302ca731 (patch)
treee221dae31e6c47db9af83a051983fa1831306016 /gnu/packages
parentc27d8597070a6dc457c228f29f97c80bd4f1e419 (diff)
downloadguix-0d55c3563c963f457cc67a728b937a67302ca731.tar
guix-0d55c3563c963f457cc67a728b937a67302ca731.tar.gz
gnu: net-tools: Install man pages and locales in share, not usr/share.
* gnu/packages/linux.scm (net-tools): Add 'INSTALLNLSDIR' and 'mandir' variables to make flags.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b5e15400e1..21daf0b06c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -690,9 +691,11 @@ manpages.")
#:parallel-build? #f
#:tests? #f ; no test suite
- #:make-flags (list "CC=gcc"
- (string-append "BASEDIR="
- (assoc-ref %outputs "out")))))
+ #:make-flags (let ((out (assoc-ref %outputs "out")))
+ (list "CC=gcc"
+ (string-append "BASEDIR=" out)
+ (string-append "INSTALLNLSDIR=" out "/share/locale")
+ (string-append "mandir=/share/man")))))
;; Use the big Debian patch set (the thing does not even compile out of
;; the box.)