aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-20 17:36:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-20 17:36:56 +0100
commit7f69459aca16756f35f08049c64a1bd77d23f33e (patch)
tree1d267fb62feab89de5d97582672540cbaa37392c /gnu/packages/xorg.scm
parent4a82722a658220ec1e10f9f2d5d77407d38db90e (diff)
parentb1989c12501e880afab62d3ff961791906fef350 (diff)
downloadguix-7f69459aca16756f35f08049c64a1bd77d23f33e.tar
guix-7f69459aca16756f35f08049c64a1bd77d23f33e.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm39
1 files changed, 31 insertions, 8 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b66d6e7f5c..b78edf53fc 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -11,8 +11,8 @@
;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2017 John Darrington <jmd@gnu.org>
-;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
@@ -3401,7 +3401,7 @@ X server.")
(define-public xf86-video-vesa
(package
(name "xf86-video-vesa")
- (version "2.3.4")
+ (version "2.4.0")
(source
(origin
(method url-fetch)
@@ -3411,7 +3411,7 @@ X server.")
".tar.bz2"))
(sha256
(base32
- "1haiw8r1z8ihk68d0jqph2wsld13w4qkl86biq46fvyxg7cg9pbv"))))
+ "1373vsxn6qh00na0s9c09kf09gj78rzi98zq93id8v5zsya3qi5z"))))
(build-system gnu-build-system)
(inputs `(("xorg-server" ,xorg-server)))
(native-inputs `(("pkg-config" ,pkg-config)))
@@ -4768,6 +4768,27 @@ but are depended upon by many other X Window System packages to provide
common definitions and porting layer.")
(license license:x11)))
+(define-public xorgproto
+ (package
+ (name "xorgproto")
+ (version "2018.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://xorg/individual/proto/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0r3fk48vp24hk4viw4fjpyh0y7rdg13p5faxc0vicdyqcn5w02cp"))))
+ (build-system gnu-build-system)
+ (propagated-inputs
+ ;; To get util-macros in (almost?) all package inputs.
+ `(("util-macros" ,util-macros)))
+ (home-page "https://cgit.freedesktop.org/xorg/proto/xorgproto")
+ (synopsis "Xorg protocol headers")
+ (description
+ "This package provides the headers and specification documents defining
+the core protocol and (many) extensions for the X Window System.")
+ (license license:x11)))
;; packages of height 2 in the propagated-inputs tree
@@ -5781,7 +5802,7 @@ to answer a question. Xmessage can also exit after a specified time.")
("libXt" ,libxt)
("xproto" ,xproto)
("libXaw" ,libxaw)))
- (home-page "http://invisible-island.net/xterm/")
+ (home-page "https://invisible-island.net/xterm/")
(synopsis "Terminal emulator for the X Window System")
(description
"The xterm program is a terminal emulator for the X Window System. It
@@ -5923,7 +5944,7 @@ basic eye-candy effects.")
(define-public xpra
(package
(name "xpra")
- (version "2.2.1")
+ (version "2.2.4")
(source
(origin
(method url-fetch)
@@ -5931,7 +5952,7 @@ basic eye-candy effects.")
version ".tar.xz"))
(sha256
(base32
- "052w92w21ywgip5p90nifn8vxqzg09by4a0ai22znhqm5mqh7qc1"))))
+ "0v8yflvisk94bfj0zg4ggdfwrig0f3ss9kjnws3zflsr33cb2hxy"))))
(build-system python-build-system)
(inputs `(("ffmpeg" ,ffmpeg)
("flac" ,flac)
@@ -5997,12 +6018,14 @@ basic eye-candy effects.")
(substitute* "setup.py"
(("/usr/lib/")
(string-append (assoc-ref outputs "out") "/lib/")))
+ ;; Use Xvfb with '-nolisten local' to disable abstract X11 sockets.
(substitute* "./xpra/scripts/config.py"
((":.*join.*xvfb.*")
(string-append ": \"" (assoc-ref inputs "xorg-server")
"/bin/Xvfb +extension Composite"
" -screen 0 5760x2560x24+32 -dpi 96 -nolisten"
- " tcp -noreset -auth $XAUTHORITY\",\n")))
+ " tcp -nolisten local -noreset -auth"
+ " $XAUTHORITY\",\n")))
(substitute* "./xpra/scripts/config.py"
(("socket-dir.*: \"\",")
"socket-dir\" : \"~/.xpra\","))