aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2017-11-15 12:22:44 +0100
committerLudovic Courtès <ludo@gnu.org>2017-11-16 10:21:40 +0100
commit42e52605d42adc42834274b6cd69863f4d717375 (patch)
tree35afb8cffb62d2ec59af42b5409d9e6cca98a9c2 /gnu/packages/xorg.scm
parentd9cd1c2272d2e1eb595f9676571e9ce01d134a21 (diff)
downloadguix-42e52605d42adc42834274b6cd69863f4d717375.tar
guix-42e52605d42adc42834274b6cd69863f4d717375.tar.gz
gnu: xpra: Fix paths.
* gnu/packages/xorg.scm (xpra): [arguments]: Add '--without-opengl', '--without-Xdummy' and '--without-Xdummy-wrapper' to #:configure-flags. Add substitutions to #phases for proper paths. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 81f4e5d103..994476ed63 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5973,6 +5973,9 @@ basic eye-candy effects.")
`(#:python ,python-2 ;; no full Python 3 support yet
#:configure-flags '("--with-tests"
"--with-bundle_tests"
+ "--without-opengl" ;; TODO: pygtkglext needed.
+ "--without-Xdummy" ;; We use Xvfb instead.
+ "--without-Xdummy_wrapper"
"--without-strict")
#:modules ((guix build python-build-system)
(guix build utils))
@@ -6001,13 +6004,15 @@ basic eye-candy effects.")
(substitute* "setup.py"
(("/usr/lib/")
(string-append (assoc-ref outputs "out") "/lib/")))
- (substitute* "./etc/xpra/conf.d/55_server_x11.conf.in"
- (("xvfb = %.*")
- (string-append "xvfb = "
- (assoc-ref inputs "xorg-server")
- "/bin/Xvfb +extension Composite -nolisten tcp"
- " -noreset -auth $XAUTHORITY"
- " -screen 0 5760x2560x24+32")))
+ (substitute* "./xpra/scripts/config.py"
+ ((":.*join.*xvfb.*")
+ (string-append ": \"" (assoc-ref inputs "xorg-server")
+ "/bin/Xvfb +extension Composite"
+ " -screen 0 5760x2560x24+32 -dpi 96 -nolisten"
+ " tcp -noreset -auth $XAUTHORITY\",\n")))
+ (substitute* "./xpra/scripts/config.py"
+ (("socket-dir.*: \"\",")
+ "socket-dir\" : \"~/.xpra\","))
#t)))))
(home-page "https://www.xpra.org/")
(synopsis "Remote access to individual applications or full desktops")