aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-05 13:27:53 -0400
committerLeo Famulari <leo@famulari.name>2016-10-05 17:37:22 -0400
commit1f90b80f8bf776cce5c312b3c519c3fa79fc79f5 (patch)
tree4d95aeddbdaa1b619212967a6c0b5a3ab322f8e6 /gnu/packages/xorg.scm
parent666d40193c1880b6b68387389fb69eda60a5c7ee (diff)
downloadguix-1f90b80f8bf776cce5c312b3c519c3fa79fc79f5.tar
guix-1f90b80f8bf776cce5c312b3c519c3fa79fc79f5.tar.gz
gnu: libxtst: Fix CVE-2016-{7951,7952}.
* gnu/packages/patches/libxtst-CVE-2016-7951-CVE-2016-7952.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/xorg.scm (libxtst)[replacement]: New field. (libxtst/fixed): New variable.
Diffstat (limited to 'gnu/packages/xorg.scm')
-rw-r--r--gnu/packages/xorg.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 2df6631e2a..111de2b65a 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4639,6 +4639,7 @@ cannot be adequately worked around on the client side of the wire.")
(define-public libxtst
(package
(name "libxtst")
+ (replacement libxtst/fixed)
(version "1.2.2")
(source
(origin
@@ -4674,6 +4675,13 @@ The RECORD extension supports the recording and reporting of all core X
protocol and arbitrary X extension protocol.")
(license license:x11)))
+(define libxtst/fixed
+ (package
+ (inherit libxtst)
+ (source (origin
+ (inherit (package-source libxtst))
+ (patches (search-patches
+ "libxtst-CVE-2016-7951-CVE-2016-7952.patch"))))))
(define-public libxv
(package