aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-04-19 19:41:05 +0200
committerAndreas Enge <andreas@enge.fr>2013-04-19 19:51:49 +0200
commitd6b8cb5c4a54c35b31304b2c96c7ab0082434d2a (patch)
treecf59e6173dc40cdaa86b5ed14701a58e63aeb7e0 /gnu/packages/xml.scm
parentf594028a9ca1908a864fecf6d9e345a83f7ee9c0 (diff)
downloadguix-d6b8cb5c4a54c35b31304b2c96c7ab0082434d2a.tar
guix-d6b8cb5c4a54c35b31304b2c96c7ab0082434d2a.tar.gz
gnu: Unify the two intltool packages.
* gnu/packages/xml.scm (intltool): Delete variable. * gnu/packages/glib.scm (intltool): Update to version 0.50.2.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm38
1 files changed, 0 insertions, 38 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 2c4cda54a3..524614b23f 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -149,41 +149,3 @@ then passed on to the Expat object on each parse call. They can also be given
as extra arguments to the parse methods, in which case they override options
given at XML::Parser creation time.")
(home-page "http://search.cpan.org/~toddr/XML-Parser-2.41/Parser.pm")))
-
-(define-public intltool
- (package
- (name "intltool")
- (version "0.50.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://launchpad.net/intltool/trunk/"
- version "/+download/intltool-"
- version ".tar.gz"))
- (sha256
- (base32
- "01j4yd7i84n9nk4ccs6yifg84pp68nr9by57jdbhj7dpdxf5rwk7"))))
- (build-system gnu-build-system)
- (propagated-inputs
- `(("perl" ,perl)
- ("perl-xml-parser" ,perl-xml-parser)))
- (arguments
- `(#:phases
- (alist-replace
- 'configure
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- (let ((configure (assoc-ref %standard-phases 'configure))
- (perl-xml-parser (assoc-ref inputs "perl-xml-parser")))
- ;; FIXME: This should be done more centrally.
- (setenv "PERL5LIB" (string-append perl-xml-parser "/lib/perl5/site_perl"))
- (apply configure args)))
- %standard-phases)))
- (home-page "https://launchpad.net/intltool/+download")
- (synopsis "Utility scripts for internationalising xml")
- (description
- "intltool automatically extracts translatable strings from oaf, glade,
-bonobo ui, nautilus theme and other XML files into the po files.
-It automatically merges translations from po files back into .oaf files
-(encoding to be 7-bit clean). The merging mechanism can also be extended to
-support other types of XML files.")
- (license license:gpl2+)))
-