aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-02-01 23:23:08 +0100
committerAndreas Enge <andreas@enge.fr>2013-02-01 23:23:08 +0100
commit58cc3b385bb573caee09213d7a4394920220269f (patch)
treed9db94405add399b342fb69df8aa88706d9fe11a /gnu/packages/xml.scm
parent38bbd61df1e647b475815f1f35f79e97799f2824 (diff)
downloadguix-58cc3b385bb573caee09213d7a4394920220269f.tar
guix-58cc3b385bb573caee09213d7a4394920220269f.tar.gz
gnu: Add libxslt.
* gnu/packages/xml.scm (libxslt): New variable.
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 642caf02b8..1d7060a044 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -19,6 +19,7 @@
(define-module (gnu packages xml)
#:use-module (gnu packages)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
#:use-module ((guix licenses)
@@ -67,3 +68,25 @@ things the parser might find in the XML document (like start tags).")
"Libxml2 is the XML C parser and toolkit developed for the Gnome project
(but it is usable outside of the Gnome platform).")
(license license:x11)))
+
+(define-public libxslt
+ (package
+ (name "libxslt")
+ (version "1.1.28")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://xmlsoft.org/libxslt/libxslt-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "13029baw9kkyjgr7q3jccw2mz38amq7mmpr5p3bh775qawd1bisz"))))
+ (build-system gnu-build-system)
+ (home-page "http://xmlsoft.org/XSLT/index.html")
+ (synopsis "libxslt, a C library for applying XSLT stylesheets to XML documents")
+ (inputs `(("libgcrypt" ,libgcrypt)
+ ("libxml2" ,libxml2)
+ ("python" ,python)))
+ (description
+ "Libxslt is an XSLT C library developed for the GNOME project. It is
+based on libxml for XML parsing, tree manipulation and XPath support.")
+ (license license:x11)))