aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-13 21:28:01 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-13 21:28:01 +0200
commit75710da66710cef1d32053cd8f350d13057d02a7 (patch)
treeabef6a326c741b1eb18db866b2f2bacee3e5fc51 /gnu/packages/xml.scm
parentab20c2cc33063ce783515d8ae7899ec7e2ca6f96 (diff)
parent610075f7c94c80b8321887b7ccf8bb1a7edd2b8e (diff)
downloadguix-75710da66710cef1d32053cd8f350d13057d02a7.tar
guix-75710da66710cef1d32053cd8f350d13057d02a7.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index c4a1b15a15..5d65648bfb 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -467,3 +467,25 @@ Canonical XML (part of Libxml2) and Exclusive Canonical XML (part of
Libxml2).")
(license (license:x11-style "file://COPYING"
"See 'COPYING' in the distribution."))))
+
+(define-public minixml
+ (package
+ (name "minixml")
+ (version "2.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.msweet.org/files/project3/mxml-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "14pzhlfidj5v1qbxy7a59yn4jz9pnjrs2zwalz228jsq7ijm9vfd"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ;no "check" target
+ (home-page "http://www.minixml.org/")
+ (synopsis "Small XML parsing library")
+ (description
+ "Mini-XML is a small C library to read and write XML files and strings in
+UTF-8 and UTF-16 encoding.")
+ ;; LGPL 2.0+ with additional exceptions for static linking
+ (license license:lgpl2.0+)))