aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-13 17:50:17 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-13 18:18:48 +0100
commit8c986ab12034d67db836a881f57c69754d8073ae (patch)
treebf5183011119695ac549d4cfff4dc2175e659397 /gnu/packages/xml.scm
parent203795aceaabec0e0e5818e1650ad407d825d1b3 (diff)
parent7a2eed3aac1ecd0bdf293e33a234fad58f2e5f9e (diff)
downloadguix-8c986ab12034d67db836a881f57c69754d8073ae.tar
guix-8c986ab12034d67db836a881f57c69754d8073ae.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 8288869a9f..7419c61d3a 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015 Raimon Grau <raimonster@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -707,3 +708,27 @@ Cflags: -I${includedir}
C++ programming langauge.")
(home-page "http://www.grinninglizard.com/tinyxml/index.html")
(license license:zlib)))
+
+(define-public xmlstarlet
+ (package
+ (name "xmlstarlet")
+ (version "1.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/xmlstar/xmlstarlet/"
+ version "/xmlstarlet-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jp737nvfcf6wyb54fla868yrr39kcbijijmjpyk4lrpyg23in0m"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libxslt" ,libxslt)
+ ("libxml2" ,libxml2)))
+ (home-page "http://xmlstar.sourceforge.net/")
+ (synopsis "Command line XML toolkit")
+ (description "XMLStarlet is a set of command line utilities which can be
+used to transform, query, validate, and edit XML documents. XPath is used to
+match and extract data, and elements can be added, deleted or modified using
+XSLT and EXSLT.")
+ (license license:x11)))