aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorTonton <tonton@riseup.net>2018-03-29 11:38:11 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-03-29 18:35:46 +0200
commitaf1e3dfe2792255e62083c87eadf15325793313e (patch)
tree43de0a20d28c4e0f4b63fd6431a6226a0c911a32 /gnu/packages/xdisorg.scm
parent95fb6b0413f9c03f54e912ca3826ccefec7a78a4 (diff)
downloadguix-af1e3dfe2792255e62083c87eadf15325793313e.tar
guix-af1e3dfe2792255e62083c87eadf15325793313e.tar.gz
gnu: Add screen-message.
* gnu/packages/xdisorg.scm (screen-message): New variable. Signed-off-by: Tonton <tonton@riseup.net> Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 6663a0e746..94192966e0 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Marek Benc <dusxmt@gmx.com>
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
+;;; Copyright © 2018 Thomas Sigurdsen <tonton@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1408,3 +1409,32 @@ or playing a PCM encoded WAVE file.")
System, and launches a program of your choice if there is no activity after
a user-configurable period of time.")
(license license:gpl2)))
+
+(define-public screen-message
+ (package
+ (name "screen-message")
+ (version "0.25")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.joachim-breitner.de/archive/screen-message"
+ "/screen-message-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lw955qq5pq010lzmaf32ylj2iprgsri9ih4hx672c3f794ilab0"))))
+ (build-system gnu-build-system)
+ (inputs `(("gtk3" ,gtk+)
+ ("gdk" ,gdk-pixbuf)
+ ("pango" ,pango)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (arguments
+ ;; The default configure puts the 'sm' binary in games/ instead of bin/ -
+ ;; this fixes it:
+ `(#:make-flags (list (string-append "execgamesdir=" %output "/bin"))))
+ (synopsis "Print messages on your screen")
+ (description "@code{screen-message} is a tool for displaying text on
+your screen. It will make the text as large as possible and display it
+with black color on a white background (colors are configurable on the
+commandline).")
+ (home-page "https://www.joachim-breitner.de/projects#screen-message")
+ (license license:gpl2+)))