aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2024-08-18 02:00:00 +0200
commited4e0b48f16530def08862657301178b5cf00a9a (patch)
tree12bcbdb18a09d54bda350c3cb6060e381e539706 /gnu/packages/xdisorg.scm
parented3649bcce1ea0db5385744f9114d4b40d6dce55 (diff)
downloadguix-ed4e0b48f16530def08862657301178b5cf00a9a.tar
guix-ed4e0b48f16530def08862657301178b5cf00a9a.tar.gz
Replace some more occurrences of ‘setuid-programs’.
* gnu/packages/containers.scm (podman, buildah)[arguments]: Substitute /run/privileged/bin for /run/setuid-programs. * gnu/packages/mail.scm (opensmtpd)[arguments]: Likewise. * gnu/packages/spice.scm (spice-gtk)[arguments]: Likewise. * gnu/packages/patches/enlightenment-fix-setuid-path.patch: Likewise. * gnu/packages/xdisorg.scm (xsecurelock)[description]: Rewrite example code to use the ‘privileged-program(s)’ terminology. * doc/guix-cookbook.texi (Network bridge for QEMU): Likewise. * gnu/packages/disk.scm (udevil)[arguments]: Update a comment. Change-Id: I7f467e8743a3ef556cd89bac41509bf51d9edb30
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 455f9170b2..180a08d13b 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2016 Petter <petter@mykolab.ch>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2021, 2024 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Marek Benc <dusxmt@gmx.com>
;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
;;; Copyright © 2018 Thomas Sigurdsen <tonton@riseup.net>
@@ -2730,15 +2730,17 @@ temperature of the screen.")
(description "@code{xsecurelock} is an X11 screen locker which uses
a modular design to avoid the usual pitfalls of screen locking utility design.
-As a consequence of the modular design, the usual screen locker service
-shouldn't be used with @code{xsecurelock}. Instead, you need to add a helper
-binary to setuid-binaries:
+As a consequence of this design, you shouldn't use the usual screen locker
+service with @code{xsecurelock}. Instead, add a helper binary to your
+@code{operating-system}'s @code{privileged-programs} field:
+
@example
-(setuid-programs
+(privileged-programs
(cons*
- (setuid-program
- (program (file-append xsecurelock \"/libexec/xsecurelock/authproto_pam\")))
- %setuid-programs))
+ (privileged-program
+ (program (file-append xsecurelock \"/libexec/xsecurelock/authproto_pam\"))
+ (setuid? #t))
+ %default-privileged-programs))
@end example")
(license license:asl2.0)))