aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-27 16:33:26 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-27 18:54:39 +0200
commit67e0fb8b496903ae2c43c9386a2bc3b0a7c28579 (patch)
tree53d4323118a76d05de20666a086d71e2d7d8b38b /gnu/packages/xdisorg.scm
parente9a041577a4c63d86ff9164bd0e0d46e59db6122 (diff)
downloadguix-67e0fb8b496903ae2c43c9386a2bc3b0a7c28579.tar
guix-67e0fb8b496903ae2c43c9386a2bc3b0a7c28579.tar.gz
gnu: Add xrandr-invert-colors.
* gnu/packages/xdisorg.scm (xrandr-invert-colors): New variable.
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index c92dbd1784..cf3e33eb5b 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -1521,3 +1521,37 @@ the X11 clipboard")
the numlock key in X11. It can be called from the user's initialization files
to automatically turn it on on login.")
(license license:expat)))
+
+(define-public xrandr-invert-colors
+ (package
+ (name "xrandr-invert-colors")
+ (version "0.01")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zoltanp/xrandr-invert-colors.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1br3x9vr6xm4ika06n8cfxx1b3wdchdqvyzjl4y1chmivrml8x9h"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "CC=gcc")
+ #:tests? #f ; there are none
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "xrandr-invert-colors.bin" bin)
+ #t))))))
+ (inputs
+ `(("libxrandr" ,libxrandr)))
+ (home-page "https://github.com/zoltanp/xrandr-invert-colors")
+ (synopsis "Invert display colors")
+ (description "This package provides a small utility for inverting the
+colors on all monitors attached to an XRandR-capable X11 display server.")
+ (license license:gpl3+)))