aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xdisorg.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-03 19:41:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-03 19:41:05 +0100
commit982eff9e841f3539e4ecf93669435a290bfde571 (patch)
treeb1e3f6fc85c6c35c264f091eb2fc5cff8514c230 /gnu/packages/xdisorg.scm
parent7ba6d70e4528201151195e1ed2175ee4828bdb2f (diff)
parent7158fe4ded47a599ceb8d556132ba83fcc686962 (diff)
downloadguix-982eff9e841f3539e4ecf93669435a290bfde571.tar
guix-982eff9e841f3539e4ecf93669435a290bfde571.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/xdisorg.scm')
-rw-r--r--gnu/packages/xdisorg.scm78
1 files changed, 78 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index f82bd9e1e8..1dbc1ba90e 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -72,6 +72,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages man)
#:use-module (gnu packages maths)
@@ -85,6 +86,7 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages xml)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages qt)
#:use-module (gnu packages xorg)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages bison)
@@ -229,6 +231,36 @@ with X11 or Wayland, or in a text terminal with ncurses.")
(license (list license:gpl3+ ; client program[s] and other sources
license:lgpl3+)))) ; library and bindings
+(define-public copyq
+(package
+ (name "copyq")
+ (version "3.9.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hluk/CopyQ.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wlwq9xg8rzsbj0b29z358k4mbrqy04iraa8x0p26pa95yskgcma"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release")
+ #:tests? #f)) ; Test suite is a rather manual process.
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtscript" ,qtscript)
+ ("qtsvg" ,qtsvg)
+ ("qtx11extras" ,qtx11extras)))
+ (synopsis "Clipboard manager with advanced features")
+ (description "CopyQ is clipboard manager with editing and scripting
+features. CopyQ monitors system clipboard and saves its content in customized
+tabs. Saved clipboard can be later copied and pasted directly into any
+application.")
+ (home-page "https://hluk.github.io/CopyQ/")
+ (license license:gpl3+)))
+
(define-public xclip
(package
(name "xclip")
@@ -1820,6 +1852,52 @@ colors on all monitors attached to an XRandR-capable X11 display server.")
temperature of the screen.")
(license (license:non-copyleft "file://sct.c")))) ; "OpenBSD" license
+(define-public xsecurelock
+ (package
+ (name "xsecurelock")
+ (version "1.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/google/xsecurelock/releases"
+ "/download/v" version "/xsecurelock-" version ".tar.gz"))
+ (sha256
+ (base32 "070gknyv0s5hz9hkc6v73m2v7ssyjwgl93b5hd4glayfqxqjbmdp"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ '("--with-pam-service-name=login"
+ "--with-xkb"
+ "--with-default-authproto-module=/run/setuid-programs/authproto_pam")))
+ (native-inputs
+ `(("pandoc" ,ghc-pandoc)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("fontconfig" ,fontconfig)
+ ("libX11" ,libx11)
+ ("libxcomposite" ,libxcomposite)
+ ("libxext" ,libxext)
+ ("libxfixes" ,libxfixes)
+ ("libxft" ,libxft)
+ ("libxmu" ,libxmu)
+ ("libxrandr" ,libxrandr)
+ ("libxscrnsaver" ,libxscrnsaver)
+ ("linux-pam" ,linux-pam)))
+ (home-page "https://github.com/google/xsecurelock")
+ (synopsis "X11 screen lock utility with the primary goal of security")
+ (description "@code{xsecurelock} is an X11 screen locker which uses
+a modular design to avoid the usual pitfalls of screen locking utility design.
+
+As a consequence of the modular design, the usual screen locker service
+shouldn't be used with @code{xsecurelock}. Instead, you need to add a helper
+binary to setuid-binaries:
+@example
+(setuid-programs (cons*
+ (file-append xsecurelock \"/libexec/xsecurelock/authproto_pam\")
+ %setuid-programs))
+@end example")
+ (license license:asl2.0)))
+
(define-public wl-clipboard
(package
(name "wl-clipboard")