aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorIvan Vilata i Balaguer <ivan@selidor.net>2016-09-21 11:19:20 +0200
committer宋文武 <iyzsong@gmail.com>2016-10-01 10:56:11 +0800
commit37356e0bf8ef930fc0db7167bb2149858f0c754f (patch)
tree53f1a2d725f3a3675aad28e6b73ebdec891fb2cf /gnu/packages/wm.scm
parentc165591d471ab92f63d7e3f01ca616dff7624482 (diff)
downloadguix-37356e0bf8ef930fc0db7167bb2149858f0c754f.tar
guix-37356e0bf8ef930fc0db7167bb2149858f0c754f.tar.gz
gnu: Add quickswitch-i3.
* gnu/packages/wm.scm (quickswitch-i3): New variable. * gnu/packages/patches/quickswitch-fix-dmenu-check.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: 宋文武 <iyzsong@gmail.com>
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 3dbd9043da..90d1dc1e33 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
+;;; Copyright © 2016 Ivan Vilata i Balaguer <ivan@selidor.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,6 +61,7 @@
#:use-module (gnu packages gperf)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages suckless)
#:use-module (guix download)
#:use-module (guix git-download))
@@ -246,6 +248,50 @@ subscribe to events.")
(define-public python2-i3-py
(package-with-python2 python-i3-py))
+(define-public quickswitch-i3
+ (let ((commit "ed692b1e8f43b95bd907ced26238ce8ccb2ed28f")
+ (revision "1")) ; Guix package revision
+ (package
+ (name "quickswitch-i3")
+ (version (string-append "2.2-" revision "."
+ (string-take commit 7)))
+ (source
+ (origin
+ ;; The latest commit is a few years old and just a couple commits
+ ;; after the last tagged release, so we use that latest commit
+ ;; instead of the release.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/proxypoke/quickswitch-for-i3.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "0447077sama80jcdg5p64zjsvafmz5rbdrirhm1adcdjhkh6iqc5"))
+ (patches (search-patches "quickswitch-fix-dmenu-check.patch"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; no tests yet
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ ;; Copy readme file to documentation directory.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((doc (string-append (assoc-ref outputs "out")
+ "/share/doc/" ,name)))
+ (install-file "README.rst" doc)
+ ;; Avoid unspecified return value.
+ #t))))))
+ (inputs
+ `(("python-i3-py" ,python-i3-py)
+ ("dmenu" ,dmenu)))
+ (home-page "https://github.com/proxypoke/quickswitch-for-i3")
+ (synopsis "Quickly change to and locate windows in the i3 window manager")
+ (description
+ "This utility for the i3 window manager allows you to quickly switch to
+and locate windows on all your workspaces, using an interactive dmenu
+prompt.")
+ (license (license:non-copyleft "http://www.wtfpl.net/txt/copying/")))))
+
(define-public xmonad
(package
(name "xmonad")