aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-01 12:58:29 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-01 12:58:29 +0100
commitd2ea806436e25773221f8c9d6631db095b5f8969 (patch)
tree6ec651e89257c3d5b66a7716011c7b6fb22dec3d /gnu/packages/wm.scm
parenta71019960603ef50335a6579bc94b6d607ae5798 (diff)
downloadguix-d2ea806436e25773221f8c9d6631db095b5f8969.tar
guix-d2ea806436e25773221f8c9d6631db095b5f8969.tar.gz
gnu: xmobar: Update to 0.25.
* gnu/packages/wm.scm (xmobar): Update to 0.25. [inputs]: Replace wireless-tools with (upstream-)unbundled ghc-iwlib. [arguments]: Add ‘with_weather’ to listified #:configure-flags.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm22
1 files changed, 15 insertions, 7 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 75e4bb63fd..0cf6c1a2de 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -503,27 +504,34 @@ tiled on several screens.")
(define-public xmobar
(package
(name "xmobar")
- (version "0.24.5")
+ (version "0.25")
(source (origin
(method url-fetch)
(uri (string-append "mirror://hackage/package/xmobar/"
name "-" version ".tar.gz"))
(sha256
(base32
- "0sdzfj2wa4wpig1i2i5n9qpwm90jp88qifsmaa7j37yhhs6snfir"))))
+ "0382r4vzqkz76jlp2069rdbwf4gh1a22r9w4rkphcn5qflw0dlb6"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-http" ,ghc-http)
+ `(("ghc-hinotify" ,ghc-hinotify)
+ ("ghc-http" ,ghc-http)
+ ("ghc-iwlib" ,ghc-iwlib)
("ghc-parsec" ,ghc-parsec)
("ghc-regex-compat" ,ghc-regex-compat)
("ghc-stm" ,ghc-stm)
("ghc-x11-xft" ,ghc-x11-xft)
- ("ghc-hinotify" ,ghc-hinotify)
- ("libxpm" ,libxpm)
- ("wireless-tools" ,wireless-tools)))
+ ("libxpm" ,libxpm)))
(arguments
`(#:configure-flags
- '("--flags=with_utf8 with_xft with_xpm with_inotify with_iwlib")))
+ (list (string-append "--flags="
+ (string-join (list "with_inotify"
+ "with_iwlib"
+ "with_utf8"
+ "with_weather"
+ "with_xft"
+ "with_xpm")
+ " ")))))
(home-page "http://xmobar.org")
(synopsis "Minimalistic text based status bar")
(description