aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-04 17:38:13 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-08-04 17:38:13 +0200
commitcb96d239e62400c97c30319ae470683a09425041 (patch)
tree83606db1bee8069210776df3a04df02e60ea5556 /gnu/packages/wm.scm
parent4f868257f3f2d15236f070dd53770232c6dbaf88 (diff)
downloadguix-cb96d239e62400c97c30319ae470683a09425041.tar
guix-cb96d239e62400c97c30319ae470683a09425041.tar.gz
gnu: i3status: Update to 2.13.
* gnu/packages/wm.scm (i3status): Update to 2.13. [arguments]: Remove #:make-flags and #:phases. Add #:out-of-source?. [native-inputs]: Add DOCBOOK-XSL, LIBXML2 and XMLTO.
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8fe94e28b4..12c019bdff 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -131,20 +131,19 @@ the leaves of a full binary tree.")
(define-public i3status
(package
(name "i3status")
- (version "2.12")
+ (version "2.13")
(source (origin
(method url-fetch)
(uri (string-append "https://i3wm.org/i3status/i3status-"
version ".tar.bz2"))
(sha256
(base32
- "06krpbijv4yi33nypg6qcn4hilcrdyarsdpd9fmr2cq46qaqiikg"))))
+ "0rhlzb96mw64z2jnhwz9nibc7pxg549626lz5642xxk5hpzwk2ff"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))
+ `(;; XXX: Do an "out of source" build to work around
+ ;; <https://github.com/i3/i3status/issues/339>.
+ #:out-of-source? #t
#:tests? #f)) ; no test suite
(inputs
`(("openlibm" ,openlibm)
@@ -156,7 +155,10 @@ the leaves of a full binary tree.")
("libcap" ,libcap)
("asciidoc" ,asciidoc)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("docbook-xsl" ,docbook-xsl)
+ ("libxml2" ,libxml2) ;for XML_CATALOG_FILES
+ ("xmlto" ,xmlto)))
(home-page "https://i3wm.org/i3status/")
(synopsis "Status bar for i3bar, dzen2, xmobar or similar programs")
(description "i3status is a small program for generating a status bar for