aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-11-19 15:01:00 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-19 15:01:00 +0100
commit2dd12924cf4a30a96262b6d392fcde58c9f10d4b (patch)
tree3f74f5426ff214a02b8f6652f6516979657a7f98 /gnu/packages/wm.scm
parent259b4f34ba2eaefeafdb7c9f9eb56ee77f16010c (diff)
parenta93447b89a5b132221072e729d13a3f17391b8c2 (diff)
downloadguix-2dd12924cf4a30a96262b6d392fcde58c9f10d4b.tar
guix-2dd12924cf4a30a96262b6d392fcde58c9f10d4b.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c72e9a452c..62a5b54608 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -42,6 +42,8 @@
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module (gnu packages haskell)
+ #:use-module (gnu packages haskell-check)
+ #:use-module (gnu packages haskell-web)
#:use-module (gnu packages base)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages perl)
@@ -541,7 +543,7 @@ experience.")
(define-public awesome
(package
(name "awesome")
- (version "4.0")
+ (version "4.2")
(source
(origin (method url-fetch)
(uri (string-append
@@ -549,7 +551,7 @@ experience.")
"master/awesome-" version ".tar.xz"))
(sha256
(base32
- "0czkcz67sab63gf5m2p2pgg05yinjx60hfb9rfyzdkkg28q9f02w"))
+ "0kwpbls9h1alxcmvxh5g9qb995fds5b2ngcr44w0ibazkyls2pdc"))
(modules '((guix build utils)
(srfi srfi-19)))
(snippet
@@ -599,6 +601,9 @@ experience.")
;; '--no-name' is used, which removes timestamps from gzip output.
#:configure-flags '("-DCOMPRESS_MANPAGES=off")
+ ;; Building awesome in its source dir is no longer supported.
+ #:out-of-source? #t
+
#:phases
(modify-phases %standard-phases
(add-before 'build 'xmlto-skip-validation
@@ -714,7 +719,7 @@ Keybinder works with GTK-based applications using the X Window System.")
(define-public spectrwm
(package
(name "spectrwm")
- (version "3.0.2")
+ (version "3.1.0")
(source
(origin
(method url-fetch)
@@ -725,7 +730,7 @@ Keybinder works with GTK-based applications using the X Window System.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "065b7j8s0lxw3p58fyf3c1mr5203pdm0kww42v245rlx0f005kl2"))))
+ "16lxcharxslf9rc39wxa3mr2nx5d8kzm9ls7p7dal8yrwr7y59dp"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags (let ((pkg-config (lambda (flag)