aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-13 23:34:58 +0200
committerMarius Bakke <marius@gnu.org>2022-07-13 23:34:58 +0200
commit4442a5db773f79e05c37e014c63b4298e7de666b (patch)
tree880a6fdce7b288eaa506828b9b500191ca60ce24 /gnu/packages/wm.scm
parent5b48591176a08bddfd0147bd854785fb4f6a62ba (diff)
parentb160795a0b65d67ff5d64447f1b97c2f009517a0 (diff)
downloadguix-4442a5db773f79e05c37e014c63b4298e7de666b.tar
guix-4442a5db773f79e05c37e014c63b4298e7de666b.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm137
1 files changed, 76 insertions, 61 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 0ea7641db3..8fef7de77b 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -37,7 +37,7 @@
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
;;; Copyright © 2020 EuAndreh <eu@euandre.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
-;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020, 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020 Niklas Eklund <niklas.eklund@posteo.net>
;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
@@ -55,6 +55,7 @@
;;; Copyright © 2022 Pier-Hugues Pellerin <ph@heykimo.com>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 Elais Player <elais@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -130,6 +131,7 @@
#:use-module (gnu packages pretty-print)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
@@ -1469,19 +1471,29 @@ its size
(define-public polybar
(package
(name "polybar")
- (version "3.5.7")
+ (version "3.6.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/polybar/polybar/releases/"
"download/" version "/polybar-" version ".tar.gz"))
(sha256
- (base32 "1nr386jdlm8qkbdf23w7lyvbfhr362s90f957fawnyi1finhw8bk"))))
+ (base32 "19azx5dpfyfh0pv4q2fcrf4p7a0pc5d13m7lnv3qy8376mbmhmzj"))))
(build-system cmake-build-system)
(arguments
;; Test is disabled because it requires downloading googletest from the
;; Internet.
- '(#:tests? #f))
+ (list #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Make polybar find its default configuration file in the
+ ;; store.
+ (add-after 'unpack 'patch-config-path
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("/etc") (string-append #$output "/etc")))
+ (substitute* "src/utils/file.cpp"
+ (("\"/etc\"") (string-append "\"" #$output "/etc\""))))))))
(inputs
(list alsa-lib
cairo
@@ -1489,6 +1501,7 @@ its size
jsoncpp
libmpdclient
libnl
+ libuv
libxcb
pulseaudio
xcb-proto
@@ -1498,12 +1511,9 @@ its size
xcb-util-wm
xcb-util-xrm))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("python-sphinx" ,python-sphinx) ; for the manual
- ;; XXX: "python" input must be located after "python-2", or the package
- ;; fails to build with "missing required python module: xcbgen".
- ("python-2" ,python-2) ; lib/xpp depends on python 2
- ("python" ,python))) ; xcb-proto depends on python 3
+ (list pkg-config
+ python-sphinx ; for the manual
+ python)) ; xcb-proto depends on python 3
(home-page "https://polybar.github.io/")
(synopsis "Fast and easy-to-use status bar")
(description "Polybar aims to help users build beautiful and highly
@@ -1538,7 +1548,7 @@ functionality to display information about the most commonly used services.")
(propagated-inputs
(list ;; As required by wlroots.pc.
eudev
- libinput
+ libinput-minimal
libxkbcommon
mesa
pixman
@@ -1595,7 +1605,7 @@ modules for building a Wayland compositor.")
gdk-pixbuf
json-c
libevdev
- libinput
+ libinput-minimal
libxkbcommon
pango
swaybg
@@ -1727,7 +1737,7 @@ display a clock or apply image manipulation techniques to the background image."
gtkmm-3
jsoncpp
libdbusmenu
- libinput
+ libinput-minimal
libmpdclient
libnl
libxml2
@@ -1811,7 +1821,7 @@ Wayland compositors supporting the wlr-output-management protocol.")
(define-public stumpwm
(package
(name "stumpwm")
- (version "20.11")
+ (version "22.05")
(source
(origin
(method git-fetch)
@@ -1820,55 +1830,60 @@ Wayland compositors supporting the wlr-output-management protocol.")
(commit version)))
(file-name (git-file-name "stumpwm" version))
(sha256
- (base32 "1ghs6ihvmb3bz4q4ys1d3h6rdi96xyiw7l2ip7jh54c25049aymf"))))
+ (base32 "12hf70mpwy0ixiyvv8sf8pkwrzz8nb12a8ybvsdpibsxfjxgxnan"))))
(build-system asdf-build-system/sbcl)
- (native-inputs `(("fiasco" ,sbcl-fiasco)
- ("texinfo" ,texinfo)
-
- ;; To build the manual.
- ("autoconf" ,autoconf)
- ("automake" ,automake)))
- (inputs `(("cl-ppcre" ,sbcl-cl-ppcre)
- ("clx" ,sbcl-clx)
- ("alexandria" ,sbcl-alexandria)))
+ (native-inputs
+ (list sbcl-fiasco
+ texinfo
+
+ ;; To build the manual.
+ autoconf
+ automake))
+ (inputs
+ (list sbcl-alexandria
+ sbcl-cl-ppcre
+ sbcl-clx))
(outputs '("out" "lib"))
(arguments
- '(#:asd-systems '("stumpwm")
- #:phases
- (modify-phases %standard-phases
- (add-after 'create-asdf-configuration 'build-program
- (lambda* (#:key outputs #:allow-other-keys)
- (build-program
- (string-append (assoc-ref outputs "out") "/bin/stumpwm")
- outputs
- #:entry-program '((stumpwm:stumpwm) 0))))
- (add-after 'build-program 'create-desktop-file
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (xsessions (string-append out "/share/xsessions")))
- (mkdir-p xsessions)
- (call-with-output-file
- (string-append xsessions "/stumpwm.desktop")
- (lambda (file)
- (format file
- "[Desktop Entry]~@
- Name=stumpwm~@
- Comment=The Stump Window Manager~@
- Exec=~a/bin/stumpwm~@
- TryExec=~@*~a/bin/stumpwm~@
- Icon=~@
- Type=Application~%"
- out)))
- #t)))
- (add-after 'install 'install-manual
- (lambda* (#:key (make-flags '()) outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (info (string-append out "/share/info")))
- (invoke "./autogen.sh")
- (invoke "sh" "./configure" "SHELL=sh")
- (apply invoke "make" "stumpwm.info" make-flags)
- (install-file "stumpwm.info" info)
- #t))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ (substitute* "stumpwm-tests.asd"
+ (("\"ALL-TESTS\"")
+ "\"RUN-PACKAGE-TESTS\" :package"))))
+ (add-after 'create-asdf-configuration 'build-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (build-program
+ (string-append (assoc-ref outputs "out") "/bin/stumpwm")
+ outputs
+ #:entry-program '((stumpwm:stumpwm) 0))))
+ (add-after 'build-program 'create-desktop-file
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (xsessions (string-append out "/share/xsessions")))
+ (mkdir-p xsessions)
+ (call-with-output-file
+ (string-append xsessions "/stumpwm.desktop")
+ (lambda (file)
+ (format file
+ "[Desktop Entry]~@
+ Name=stumpwm~@
+ Comment=The Stump Window Manager~@
+ Exec=~a/bin/stumpwm~@
+ TryExec=~@*~a/bin/stumpwm~@
+ Icon=~@
+ Type=Application~%"
+ out))))))
+ (add-after 'install 'install-manual
+ (lambda* (#:key (make-flags '()) outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (info (string-append out "/share/info")))
+ (invoke "./autogen.sh")
+ (invoke "sh" "./configure" "SHELL=sh")
+ (apply invoke "make" "stumpwm.info" make-flags)
+ (install-file "stumpwm.info" info)))))))
(synopsis "Window manager written in Common Lisp")
(description "Stumpwm is a window manager written entirely in Common Lisp.
It attempts to be highly customizable while relying entirely on the keyboard
@@ -2564,7 +2579,7 @@ read and write, and compatible with JSON.")
(list bmake pkg-config wayland-protocols))
(inputs
`(("cairo" ,cairo)
- ("libinput" ,libinput)
+ ("libinput" ,libinput-minimal)
("libucl" ,libucl)
("libxkbcommon" ,libxkbcommon)
("pam" ,linux-pam)