aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wine.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-01-02 11:34:17 +0100
committerRutger Helling <rhelling@mykolab.com>2018-01-02 11:40:02 +0100
commit1adc6013fe3c7bc8e7f9b83268c0cc328b1a3fea (patch)
tree1747780c50b7d9ed482f562ee64697f52d328701 /gnu/packages/wine.scm
parent68e4921130a9ff8231e971df06dbe4a71998165c (diff)
downloadguix-1adc6013fe3c7bc8e7f9b83268c0cc328b1a3fea.tar
guix-1adc6013fe3c7bc8e7f9b83268c0cc328b1a3fea.tar.gz
gnu: wine64-staging: Copy missing man file.
* gnu/packages/wine.scm (wine64-staging)[arguments]: Copy missing man file from "wine-staging" input. Clarify 'copy-wine32-files phase with comments. [synopsis]: Use proper "WoW64" term.
Diffstat (limited to 'gnu/packages/wine.scm')
-rw-r--r--gnu/packages/wine.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 91aa56de4c..857047e733 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -270,6 +270,7 @@ integrated into the main branch.")
(modify-phases %standard-phases
(add-after 'install 'copy-wine32-files
(lambda* (#:key outputs #:allow-other-keys)
+ ;; Copy the 32-bit binaries needed for WoW64.
(copy-file (string-append (assoc-ref %build-inputs "wine-staging")
"/bin/wine") (string-append (assoc-ref
%outputs "out") "/bin/wine"))
@@ -277,6 +278,12 @@ integrated into the main branch.")
"/bin/wine-preloader") (string-append
(assoc-ref %outputs "out")
"/bin/wine-preloader"))
+ ;; Copy the missing man file for the wine binary from wine-staging.
+ (system (string-append "gunzip < " (string-append (assoc-ref
+ %build-inputs "wine-staging")
+ "/share/man/man1/wine.1.gz") "> "
+ (string-append (assoc-ref %outputs "out")
+ "/share/man/man1/wine.1")))
#t))
(add-after 'configure 'patch-dlopen-paths
;; Hardcode dlopened sonames to absolute paths.
@@ -295,6 +302,6 @@ integrated into the main branch.")
,@(strip-keyword-arguments '(#:configure-flags #:make-flags #:phases
#:system)
(package-arguments wine-staging))))
- (synopsis "Implementation of the Windows API (staging branch, WOW64
+ (synopsis "Implementation of the Windows API (staging branch, WoW64
version)")
(supported-systems '("x86_64-linux" "aarch64-linux"))))