aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-01-28 07:29:13 -0500
committerMark H Weaver <mhw@netris.org>2016-01-28 07:29:13 -0500
commit593c366bded5d5f6638a3e80edb1c6e473149fce (patch)
treeeb58d26a878a22c79931fd8cfc2479dea28ab0a6 /gnu/packages/webkit.scm
parent133056bd743e4a3d534a4e4ba9ed83dbbfbfbd19 (diff)
parent29a780147d066d5ce218d1fa2678a0a36a1145e3 (diff)
downloadguix-593c366bded5d5f6638a3e80edb1c6e473149fce.tar
guix-593c366bded5d5f6638a3e80edb1c6e473149fce.tar.gz
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 0706d92c36..f902433786 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -81,7 +81,7 @@
;; that it will be in the same directory as gstreamer's header
;; files.
(setenv "CPATH"
- (string-append (getenv "CPATH")
+ (string-append (getenv "C_INCLUDE_PATH")
":"
(assoc-ref inputs "gst-plugins-base")
"/include/gstreamer-1.0")))))))
@@ -149,6 +149,11 @@ HTML/CSS applications to full-fledged web browsers.")
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no tests
+ ;; FIXME: Disabling parallel building is a quick hack to avoid the
+ ;; failure described in
+ ;; https://lists.gnu.org/archive/html/guix-devel/2016-01/msg00837.html
+ ;; A more structural fix is needed.
+ #:parallel-build? #f
#:phases (modify-phases %standard-phases
(add-after
'unpack 'set-gcc
@@ -163,7 +168,12 @@ HTML/CSS applications to full-fledged web browsers.")
(package (inherit webkitgtk-2.4)
(name "webkitgtk-gtk2")
(arguments
- `(#:configure-flags
+ `(;; FIXME: Disabling parallel building is a quick hack to avoid the
+ ;; failure described in
+ ;; https://lists.gnu.org/archive/html/guix-devel/2016-01/msg00837.html
+ ;; A more structural fix is needed.
+ #:parallel-build? #f
+ #:configure-flags
'("--enable-webkit2=no"
"--with-gtk=2.0")
,@(package-arguments webkitgtk-2.4)))