aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-05-06 08:38:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-05-07 20:17:42 +0200
commit7b05ba9161579004ace734efc42d48c6f1708d5c (patch)
treee2b1ddf8569049840c3d695c430889e99d3c6412 /gnu/packages/webkit.scm
parentc024ae3601d645fc332ba97895a77454433003b3 (diff)
downloadguix-7b05ba9161579004ace734efc42d48c6f1708d5c.tar
guix-7b05ba9161579004ace734efc42d48c6f1708d5c.tar.gz
gnu: Add WebkitGTK 2.4.8.
* gnu/packages/webkit.scm (webkitgtk-2.4): New variable. * gnu/packages/patches/webkitgtk-2.4.8-gmutexlocker.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index 9692ab0d36..b091c88601 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,9 +23,13 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages base)
#:use-module (gnu packages bison)
#:use-module (gnu packages databases)
#:use-module (gnu packages enchant)
+ #:use-module (gnu packages flex)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
@@ -108,3 +113,30 @@ HTML/CSS applications to full-fledged web browsers.")
license:lgpl2.1+
license:bsd-2
license:bsd-3))))
+
+(define-public webkitgtk-2.4
+ ;; Latest release of the stable 2.4 series.
+ (package (inherit webkitgtk)
+ (name "webkitgtk")
+ (version "2.4.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.webkitgtk.org/releases/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "08xxqsxpa63nzgbsz63vrdxdxgpysyiy7jdcjb57k1hprdcibwb8"))
+ (patches (list (search-patch "webkitgtk-2.4.8-gmutexlocker.patch")))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:phases (modify-phases %standard-phases
+ (add-after
+ 'unpack 'set-gcc
+ (lambda _ (setenv "CC" "gcc") #t)))
+ #:configure-flags '("--enable-webkit2=no"
+ "--with-gtk=2.0")))
+ (inputs
+ `(("flex" ,flex)
+ ("which" ,which)
+ ,@(package-inputs webkitgtk)))))