aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-04 14:07:23 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-04 14:07:23 +0100
commit1289062522e3d08259740e59243c6cd0642a9916 (patch)
tree65857ae41001e3b33db621073cf1504de601dda1 /gnu/packages/web.scm
parentcb4d3d863b3fb44d97b3b568ff9e6cfe38f1f630 (diff)
parentda699774d4d839a45daa3ae3b9189331c490b315 (diff)
downloadguix-1289062522e3d08259740e59243c6cd0642a9916.tar
guix-1289062522e3d08259740e59243c6cd0642a9916.tar.gz
Merge branch 'core-updates'.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index fd1d6dd4c7..5f917511f9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Aljosha Papsch <misc@rpapsch.de>
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;;
@@ -263,18 +263,11 @@ for efficient socket-like bidirectional reliable communication channels.")
("which" ,which)
("libtool" ,libtool)))
(arguments
- `(#:phases (alist-cons-before
- 'bootstrap 'fix-autogen-shebang
+ `(#:phases (alist-cons-after
+ 'unpack 'bootstrap
(lambda _
- (substitute* "autogen.sh"
- ;; Removing -e as it causes the whole script to fail when
- ;; `which gtkdocize` fails.
- (("# !/bin/sh -e") (string-append "#!" (which "sh")))))
- (alist-cons-before
- 'patch-usr-bin-file 'bootstrap
- (lambda _
- (zero? (system* "./autogen.sh")))
- %standard-phases))))
+ (zero? (system* "sh" "autogen.sh")))
+ %standard-phases)))
(home-page "https://github.com/rockdaboot/libpsl")
(synopsis "C library for the Publix Suffix List")
(description