aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-10 17:14:26 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-11 15:48:06 -0500
commitc3c03bebd1e34ca2a40a46af08d0ae99e11bab15 (patch)
tree4615591dc50e8c99c530ebd125f5da2dad19cf01 /gnu/packages/web.scm
parent2b63ebc1fea2bacca53c40e2805f4daa48d1f4bc (diff)
downloadguix-c3c03bebd1e34ca2a40a46af08d0ae99e11bab15.tar
guix-c3c03bebd1e34ca2a40a46af08d0ae99e11bab15.tar.gz
gnu: Add HTTP-Tiny.
* gnu/packages/web.scm (perl-http-tiny): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 18a193c539..7da10cf3be 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -759,6 +759,31 @@ of the negotiable variants and the value of the various Accept* header
fields in the request.")
(home-page "http://search.cpan.org/~gaas/HTTP-Negotiate/")))
+(define-public perl-http-tiny
+ (package
+ (name "perl-http-tiny")
+ (version "0.053")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
+ "HTTP-Tiny-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1bwy31xrcz5zfx1n3vc50vj1aqvzn5ccr7lgacl8wmi03a6w2af2"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("perl-http-cookiejar" ,perl-http-cookiejar)
+ ("perl-io-socket-ip" ,perl-io-socket-ip)
+ ("perl-io-socket-ssl" ,perl-io-socket-ssl)
+ ("perl-net-ssleay" ,perl-net-ssleay)))
+ (home-page "http://search.cpan.org/dist/HTTP-Tiny")
+ (synopsis "HTTP/1.1 client")
+ (description "This is a very simple HTTP/1.1 client, designed for doing
+simple requests without the overhead of a large framework like LWP::UserAgent.
+It supports proxies and redirection. It also correctly resumes after EINTR.")
+ (license (package-license perl))))
+
(define-public perl-io-html
(package
(name "perl-io-html")