aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-17 13:28:53 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-19 16:43:29 -0500
commit5bb82fd0b425c82320bb5b2ff45e5d3f4811823d (patch)
tree9615357f9cf3a0455caf61a5b07f1841776b4c70 /gnu/packages/web.scm
parent9a5c4cd8b02fc29f91516d4830fc4467daeeb2e1 (diff)
downloadguix-5bb82fd0b425c82320bb5b2ff45e5d3f4811823d.tar
guix-5bb82fd0b425c82320bb5b2ff45e5d3f4811823d.tar.gz
gnu: Add URI-Find.
* gnu/packages/web.scm (perl-uri-find): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 62adab3952..0e94269af1 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1319,6 +1319,29 @@ represent \"Uniform Resource Identifier references\" as specified in RFC 2396
and updated by RFC 2732.")
(home-page "http://search.cpan.org/dist/URI/")))
+(define-public perl-uri-find
+ (package
+ (name "perl-uri-find")
+ (version "20140709")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MS/MSCHWERN/"
+ "URI-Find-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0czc4h182s7sx3k123m7qlg7yybnwxgh369hap3c3b6xgrglrhy0"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-uri" ,perl-uri)))
+ (home-page "http://search.cpan.org/dist/URI-Find")
+ (synopsis "Find URIs in arbitrary text")
+ (description "This module finds URIs and URLs (according to what URI.pm
+considers a URI) in plain text. It only finds URIs which include a
+scheme (http:// or the like), for something a bit less strict, consider
+URI::Find::Schemeless. For a command-line interface, urifind is provided.")
+ (license (package-license perl))))
+
(define-public perl-uri-ws
(package
(name "perl-uri-ws")