aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-17 14:44:52 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-19 16:43:30 -0500
commit4b4fe57dc9a27436e9a13c8a34579a0211aadbb7 (patch)
tree62b99a72bf1b27f9f473175496e4c32c80977bc4 /gnu/packages/web.scm
parent3d4644e4346b344d8c17462521096bf1af3bcc0e (diff)
downloadguix-4b4fe57dc9a27436e9a13c8a34579a0211aadbb7.tar
guix-4b4fe57dc9a27436e9a13c8a34579a0211aadbb7.tar.gz
gnu: Add Catalyst-Plugin-Authentication.
* gnu/packages/web.scm (perl-catalyst-plugin-authentication): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a54a1e9889..4c058d027d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -555,6 +555,40 @@ action with the generated name, and failing that it will try to dispatch to a
regular method.")
(license (package-license perl))))
+(define-public perl-catalyst-plugin-authentication
+ (package
+ (name "perl-catalyst-plugin-authentication")
+ (version "0.10023")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/B/BO/BOBTFISH/"
+ "Catalyst-Plugin-Authentication-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0v6hb4r1wv3djrnqvnjcn3xx1scgqzx8nyjdg9lfc1ybvamrl0rn"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-catalyst-plugin-session" ,perl-catalyst-plugin-session)
+ ("perl-catalyst-runtime" ,perl-catalyst-runtime)
+ ("perl-class-inspector" ,perl-class-inspector)
+ ("perl-moose" ,perl-moose)
+ ("perl-moosex-emulate-class-accessor-fast"
+ ,perl-moosex-emulate-class-accessor-fast)
+ ("perl-mro-compat" ,perl-mro-compat)
+ ("perl-namespace-autoclean" ,perl-namespace-autoclean)
+ ("perl-string-rewriteprefix" ,perl-string-rewriteprefix)
+ ("perl-test-exception" ,perl-test-exception)
+ ("perl-try-tiny" ,perl-try-tiny)))
+ (home-page "http://search.cpan.org/dist/Catalyst-Plugin-Authentication")
+ (synopsis "Infrastructure plugin for the Catalyst authentication framework")
+ (description "The authentication plugin provides generic user support for
+Catalyst apps. It is the basis for both authentication (checking the user is
+who they claim to be), and authorization (allowing the user to do what the
+system authorises them to do).")
+ (license (package-license perl))))
+
(define-public perl-catalyst-plugin-session
(package
(name "perl-catalyst-plugin-session")