aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-04 10:15:24 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-04 10:15:24 +0100
commit1c4a00820a1ba6265d2d96f4f7804d0807d69dcc (patch)
treeff97a8275a873954fddd56adb402e16bd5f71485 /gnu/packages/web.scm
parent3e2442de5268782213b04048463fcbc5d76accd7 (diff)
downloadguix-1c4a00820a1ba6265d2d96f4f7804d0807d69dcc.tar
guix-1c4a00820a1ba6265d2d96f4f7804d0807d69dcc.tar.gz
gnu: ikiwiki: Fix build by disabling a test.
* gnu/packages/web.scm (ikiwiki)[arguments]: In stage "pre-check", disable failing "t/t.po" test. Change-Id: I4fc1240512b4d3df3ece837521116aee5746e181
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b10c03a7f4..88b39e9942 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -40,7 +40,7 @@
;;; Copyright © 2019, 2020 Florian Pelz <pelzflorian@pelzflorian.de>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2020, 2021, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020, 2021, 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018, 2019, 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2020, 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
@@ -5920,6 +5920,8 @@ NetSurf project.")
(setenv "XDG_DATA_DIRS"
(string-append (assoc-ref inputs "shared-mime-info")
"/share"))
+ ;; This test fails: "Cannot read from a file without refname".
+ (rename-file "t/po.t" "t/po.t-")
;; CC is needed by IkiWiki/Wrapper.pm.
(setenv "CC" "gcc")))
(add-after 'install 'wrap-programs