aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-05 19:15:39 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-05 19:15:39 +0200
commitcf6db76d2af2f287f12928df160447ab4165b3e5 (patch)
tree49a1309c0e04c00090ab106f7ae3495a6da328c1 /gnu/packages/web.scm
parente65b2181e8b436278e3dd0b405602a400fbd0a75 (diff)
parenta6798218bea0d6b2df598042d1ced29f74bb4250 (diff)
downloadguix-cf6db76d2af2f287f12928df160447ab4165b3e5.tar
guix-cf6db76d2af2f287f12928df160447ab4165b3e5.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm51
1 files changed, 29 insertions, 22 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 0cbade457f..4a8699c4c0 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -124,14 +124,14 @@
(define-public httpd
(package
(name "httpd")
- (version "2.4.34")
+ (version "2.4.35")
(source (origin
(method url-fetch)
(uri (string-append "mirror://apache/httpd/httpd-"
version ".tar.bz2"))
(sha256
(base32
- "1w1q2smdgf6ln0x741lk5pv5r0gzrxj2iza1vslhifzy65bcjlzs"))))
+ "0mlvwsm7hmpc7db6lfc2nx3v4cll3qljjxhjhgsw6aniskywc1r6"))))
(build-system gnu-build-system)
(native-inputs `(("pcre" ,pcre "bin"))) ;for 'pcre-config'
(inputs `(("apr" ,apr)
@@ -1862,15 +1862,15 @@ MIME type directly to the browser, without being processed through Catalyst.")
(define-public perl-catalyst-runtime
(package
(name "perl-catalyst-runtime")
- (version "5.90118")
+ (version "5.90119")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/H/HA/HAARG/"
+ (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
"Catalyst-Runtime-" version ".tar.gz"))
(sha256
(base32
- "0cws3szx3vvh0372qdx8fypgv6qphcc3v81rbq30sl1ghby7ksd3"))))
+ "1iw7x9rqk3sz2hm1bw01blz5vwm7zlljdf4xj3r8vz54f1yggzqr"))))
(build-system perl-build-system)
(native-inputs
`(("perl-test-fatal" ,perl-test-fatal)))
@@ -5173,7 +5173,7 @@ functions of Tidy.")
(define-public hiawatha
(package
(name "hiawatha")
- (version "10.7")
+ (version "10.8.3")
(source
(origin
(method url-fetch)
@@ -5181,28 +5181,34 @@ functions of Tidy.")
"hiawatha-" version ".tar.gz"))
(modules '((guix build utils)))
(snippet '(begin
- ;; We use our packaged mbedtls, so delete the included copy.
- (delete-file-recursively "mbedtls")
+ ;; We use packaged libraries, so delete the bundled copies.
+ (for-each delete-file-recursively
+ (list "nghttp2" "mbedtls"))
#t))
(sha256
(base32
- "0x2zfc8kc6c7rl4gwymwmg13w1c60biv6c6c9fvzpnl59bc9jgin"))))
+ "0w7047pwijhsbvvv1qjynp7gvn0nil56w82f7ax0gabrg7ddzk6s"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; No tests included
+ `(#:tests? #f ; no tests included
#:configure-flags (list (string-append "-DUSE_SYSTEM_MBEDTLS=on")
+ (string-append "-DENABLE_HTTP2=on")
+ (string-append "-DUSE_SYSTEM_NGHTTP2=on")
(string-append "-DENABLE_TOMAHAWK=on")
+ (string-append "-DLOG_DIR=/var/log/hiawatha")
+ (string-append "-DPID_DIR=/run")
(string-append "-DWEBROOT_DIR="
(assoc-ref %outputs "out")
- "/share/hiawatha/html"))
+ "/share/hiawatha/html")
+ (string-append "-DWORK_DIR=/var/lib/hiawatha"))
#:phases
(modify-phases %standard-phases
- (add-after 'install 'remove-empty-dirs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- ;; The directories in "var" are empty, remove them.
- (delete-file-recursively (string-append out "/var"))
- #t)))
+ (add-after 'unpack 'install-no-empty-directories
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("install\\(DIRECTORY DESTINATION" match)
+ (string-append "#" match)))
+ #t))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make sure 'hiawatha' finds 'mbedtls'.
@@ -5212,11 +5218,12 @@ functions of Tidy.")
(wrap-program (string-append sbin "/hiawatha")
`("PATH" ":" prefix (,mbed)))))))))
(inputs
- ;; TODO: package "hiawatha-monitor", an optional dependency of "hiawatha"
- `(("mbedtls-apache" ,mbedtls-apache) ;Hiawatha includes this version.
- ("zlib" ,zlib)
- ("libxslt" ,libxslt)
- ("libxml2" ,libxml2)))
+ ;; TODO: package "hiawatha-monitor", an optional dependency of "hiawatha".
+ `(("libxslt" ,libxslt)
+ ("libxml2" ,libxml2)
+ ("mbedtls-apache" ,mbedtls-for-hiawatha)
+ ("nghttp2" ,nghttp2 "lib")
+ ("zlib" ,zlib)))
(home-page "https://www.hiawatha-webserver.org")
(synopsis "Webserver with focus on security")
(description