aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-11-06 15:13:16 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-11-06 15:34:36 +0100
commit418dd6adb5de1bc26ff9bac1cb0dc7822be52112 (patch)
tree3ff1ad6481f6bfeb811ccbaf482e202f90254e6a /gnu/packages/web.scm
parentc58f3ebaf8e0dc0654dc0a0096b5cffc7d6bd2ec (diff)
downloadguix-418dd6adb5de1bc26ff9bac1cb0dc7822be52112.tar
guix-418dd6adb5de1bc26ff9bac1cb0dc7822be52112.tar.gz
gnu: jq: Update to 1.6.
* gnu/packages/web.scm (jq): Update to 1.6. [source]: Remove upstreamed patch. * gnu/packages/patches/jq-CVE-2015-8863.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 447a899544..86e748f950 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4166,7 +4166,7 @@ It uses the uwsgi protocol for all the networking/interprocess communications.")
(define-public jq
(package
(name "jq")
- (version "1.5")
+ (version "1.6")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/stedolan/" name
@@ -4174,11 +4174,7 @@ It uses the uwsgi protocol for all the networking/interprocess communications.")
"/" name "-" version ".tar.gz"))
(sha256
(base32
- "0g29kyz4ykasdcrb0zmbrp2jqs9kv1wz9swx849i2d1ncknbzln4"))
- ;; This patch has been pushed and the vulnerability will be
- ;; fixed in the next release after 1.5.
- ;; https://github.com/stedolan/jq/issues/995
- (patches (search-patches "jq-CVE-2015-8863.patch"))))
+ "1a76f46a652i2g333kfvrl6mp2w7whf6h1yly519izg4y967h9cn"))))
(inputs
`(("oniguruma" ,oniguruma)))
(native-inputs