aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2018-11-12 02:23:27 +0800
committerAlex Vong <alexvong1995@gmail.com>2018-11-22 03:20:49 +0800
commit078e2edf1d3ce8e208dbb891ae662a0db3376c1e (patch)
treec3de312bb2e5e91a627787d00cf170fc3c801491 /gnu/packages/web.scm
parent6e35bad0a9d00f1eb94bb427ad856c219655e95d (diff)
downloadguix-078e2edf1d3ce8e208dbb891ae662a0db3376c1e.tar
guix-078e2edf1d3ce8e208dbb891ae662a0db3376c1e.tar.gz
gnu: Add json-parser.
* gnu/packages/web.scm (json-parser): New variable.
Diffstat (limited to 'gnu/packages/web.scm')
-rw-r--r--gnu/packages/web.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 73219c864f..eeaaa85702 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -582,6 +583,37 @@ It aims to conform to RFC 7159.")
(("-Werror") ""))
#t))))))
+(define-public json-parser
+ (package
+ (name "json-parser")
+ (version "1.1.0")
+ (source (origin
+ ;; do not use auto-generated tarballs
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/udp/json-parser.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ls7z4fx0sq633s5bc0j1gh36sv087gmrgr7rza22wjq2d4606yf"))))
+ ;; FIXME: we should build the python bindings in a separate package
+ (build-system gnu-build-system)
+ ;; the tests are written for the python bindings which are not built here
+ (arguments '(#:tests? #f))
+ (home-page "https://github.com/udp/json-parser")
+ (synopsis "JSON parser written in ANSI C")
+ (description "This package provides a very low footprint JSON parser
+written in portable ANSI C.
+
+@itemize
+@item BSD licensed with no dependencies (i.e. just drop the C file into your
+project)
+@item Never recurses or allocates more memory than it needs
+@item Very simple API with operator sugar for C++
+@end itemize")
+ (license l:bsd-2)))
+
(define-public qjson
(package
(name "qjson")