aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/web-browsers.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
committerMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
commit32787d652460871a79f99b63230f92759e2e0de2 (patch)
treece883cac0d602b10b7c005755d035a08197e73a9 /gnu/packages/web-browsers.scm
parent052939c2f6e36de00a5e756ea29a4cc96884a55d (diff)
parentc2396ceb6eb30ac87755eb8b39583403b35fbd12 (diff)
downloadguix-32787d652460871a79f99b63230f92759e2e0de2.tar
guix-32787d652460871a79f99b63230f92759e2e0de2.tar.gz
Merge branch 'master' into staging
Conflicts: gnu/local.mk gnu/packages/gdb.scm gnu/packages/lisp-xyz.scm gnu/packages/web-browsers.scm
Diffstat (limited to 'gnu/packages/web-browsers.scm')
-rw-r--r--gnu/packages/web-browsers.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 3ea4f7f867..b2209cbb2a 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -461,7 +461,7 @@ driven and does not detract you from your daily work.")
(name "nyxt")
;; Package the pre-release because latest stable 1.5.0 does not build
;; anymore.
- (version "2-pre-release-2")
+ (version "2-pre-release-3")
(source
(origin
(method git-fetch)
@@ -472,7 +472,7 @@ driven and does not detract you from your daily work.")
(commit version)))
(sha256
(base32
- "0wqq8ppn0n7js3pxzzb36h0lf3r3gqhs2hi8h85c3n8a54hnbp8q"))
+ "16crhc89hpvzkms5fypq9vdrf7glidqwh7yvy5cdmjdq4v7fkmy4"))
(file-name (git-file-name "nyxt" version))))
(build-system gnu-build-system)
(arguments
@@ -482,7 +482,8 @@ driven and does not detract you from your daily work.")
#:strip-binaries? #f ; Stripping breaks SBCL binaries.
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-version ; Version is guessed from .git which Guix does not have.
+ ;; Version is guessed from .git which Guix does not have.
+ (add-after 'unpack 'patch-version
(lambda* (#:key inputs #:allow-other-keys)
(let ((version (format #f "~a" ,version))
(file "source/global.lisp"))
@@ -515,7 +516,8 @@ driven and does not detract you from your daily work.")
":"))
(gi-path (string-join
(map (lambda (lib)
- (string-append (assoc-ref inputs lib) "/lib/girepository-1.0"))
+ (string-append (assoc-ref inputs lib)
+ "/lib/girepository-1.0"))
libs)
":"))
(xdg-path (string-join
@@ -536,6 +538,7 @@ driven and does not detract you from your daily work.")
(inputs
`(("alexandria" ,sbcl-alexandria)
("bordeaux-threads" ,sbcl-bordeaux-threads)
+ ("cl-chanl" ,sbcl-chanl)
("cl-containers" ,sbcl-cl-containers)
("cl-css" ,sbcl-cl-css)
("cl-json" ,sbcl-cl-json)
@@ -567,6 +570,7 @@ driven and does not detract you from your daily work.")
("trivial-package-local-nicknames" ,sbcl-trivial-package-local-nicknames)
("trivial-types" ,sbcl-trivial-types)
("unix-opts" ,sbcl-unix-opts)
+ ("usocket" ,sbcl-usocket)
;; WebKitGTK deps
("cl-cffi-gtk" ,sbcl-cl-cffi-gtk)
("cl-webkit" ,sbcl-cl-webkit)
@@ -588,7 +592,7 @@ key-bindings and is fully configurable and extensible in Common Lisp.")
(define-public bombadillo
(package
(name "bombadillo")
- (version "2.2.0")
+ (version "2.3.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -596,7 +600,7 @@ key-bindings and is fully configurable and extensible in Common Lisp.")
(commit version)))
(sha256
(base32
- "1m52b1wk48gkqmjy8l0x3jaksrx2v8w6w59lhr7zaw2i0n4f5k0z"))
+ "0n0gza9qfx1hxigicyvf6wg1ccc2irvh17yhzpw9gx75ls5ybrjn"))
(file-name (git-file-name name version))))
(build-system go-build-system)
(arguments
@@ -615,7 +619,6 @@ key-bindings and is fully configurable and extensible in Common Lisp.")
(pixdir (string-append sharedir "/pixmaps")))
(with-directory-excursion builddir
(install-file "bombadillo.desktop" appdir)
- (install-file "LICENSE" docdir)
(install-file "bombadillo.1" mandir)
(install-file "bombadillo-icon.png" pixdir)
#t)))))))