aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vulkan.scm
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-01-31 14:20:02 +0100
committerRutger Helling <rhelling@mykolab.com>2018-01-31 14:26:40 +0100
commita9342820d32e1dfcf6cd5834356ccefdca41aae0 (patch)
tree8b774de96192877896efac9d835e2ebf491a2d8f /gnu/packages/vulkan.scm
parenta4f99103cacf5bdfc8c4880ca37008f9d0b38dea (diff)
downloadguix-a9342820d32e1dfcf6cd5834356ccefdca41aae0.tar
guix-a9342820d32e1dfcf6cd5834356ccefdca41aae0.tar.gz
gnu: spirv-tools: Update to commit 90862fe4b1c6763b32ce683d2d32c2f281f577cf.
* gnu/packages/vulkan.scm (spirv-tools): Update to commit 90862fe4b1c6763b32ce683d2d32c2f281f577cf.
Diffstat (limited to 'gnu/packages/vulkan.scm')
-rw-r--r--gnu/packages/vulkan.scm57
1 files changed, 31 insertions, 26 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index e82bac68b0..81e5d1f2a0 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -74,36 +74,41 @@ and for the GLSL.std.450 extended instruction set.
commit "/LICENSE"))))))
(define-public spirv-tools
- (package
- (name "spirv-tools")
- (version "2017.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/KhronosGroup/SPIRV-Tools/archive/v"
- version ".tar.gz"))
+ ;; Keep updated in accordance with
+ ;; https://github.com/google/shaderc/blob/known-good/known_good.json
+ (let ((commit "90862fe4b1c6763b32ce683d2d32c2f281f577cf")
+ (revision "1"))
+ (package
+ (name "spirv-tools")
+ (version (string-append "0.0-" revision "." (string-take commit 9)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/KhronosGroup/SPIRV-Tools")
+ (commit commit)))
(sha256
(base32
- "009vflaa71a7xhvmm23f4sdbcgdkl1k4facqkwsg6djha2sdpsqq"))
- (file-name (string-append name "-" version ".tar.gz"))))
- (build-system cmake-build-system)
- (arguments
- `(#:configure-flags (list (string-append "-DCMAKE_INSTALL_LIBDIR="
- (assoc-ref %outputs "out")
- "/lib")
- (string-append "-DSPIRV-Headers_SOURCE_DIR="
- (assoc-ref %build-inputs
- "spirv-headers")))))
- (inputs `(("spirv-headers" ,spirv-headers)))
- (native-inputs `(("pkg-config", pkg-config)
- ("python" ,python)))
- (home-page "https://github.com/KhronosGroup/SPIRV-Tools")
- (synopsis "API and commands for processing SPIR-V modules")
- (description
- "The SPIR-V Tools project provides an API and commands for processing
+ "1yq8ab6f52wcxm2azzmx70nqz8l35izd45830aikjkk1jfzmzabb"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags (list (string-append "-DCMAKE_INSTALL_LIBDIR="
+ (assoc-ref %outputs "out")
+ "/lib")
+ (string-append "-DSPIRV-Headers_SOURCE_DIR="
+ (assoc-ref %build-inputs
+ "spirv-headers")))))
+ (inputs `(("spirv-headers" ,spirv-headers)))
+ (native-inputs `(("pkg-config", pkg-config)
+ ("python" ,python)))
+ (home-page "https://github.com/KhronosGroup/SPIRV-Tools")
+ (synopsis "API and commands for processing SPIR-V modules")
+ (description
+ "The SPIR-V Tools project provides an API and commands for processing
SPIR-V modules. The project includes an assembler, binary module parser,
disassembler, validator, and optimizer for SPIR-V.")
- (license license:asl2.0)))
+ (license license:asl2.0))))
(define-public glslang
;; Version 3.0 is too old for vulkan-icd-loader. Use a recent git commit