aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vpn.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-12-19 04:13:59 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-12-19 04:13:59 +0100
commitc0b12a606b6af07e739b8326e032774245f38297 (patch)
treec8c326ef0f0762d512393fb4b3d275e0ae9ea603 /gnu/packages/vpn.scm
parent1c1b67a3c91cd46241dee9c556d326e11b1d9ce2 (diff)
downloadguix-c0b12a606b6af07e739b8326e032774245f38297.tar
guix-c0b12a606b6af07e739b8326e032774245f38297.tar.gz
gnu: sshoot: Fix tests.
* gnu/packages/vpn.scm (sshoot)[arguments]: Add 'patch-paths' phase.
Diffstat (limited to 'gnu/packages/vpn.scm')
-rw-r--r--gnu/packages/vpn.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index a32ac206ac..9a08ad4f41 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -247,6 +247,14 @@ DNS domain name queries.")
(base32
"0a92lk8790dpp9j64vb6p4sazax0x3nby01lnfll7mxs1hx6n27q"))))
(build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda _
+ (substitute* "sshoot/tests/test_manager.py"
+ (("/bin/sh") (which "sh")))
+ #t)))))
(inputs
`(("python-argcomplete" ,python-argcomplete)
("python-prettytable" ,python-prettytable)