aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-18 11:54:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-18 11:54:54 +0200
commit993a4fbb7c3d1f9977e0789c21905fddd72241fd (patch)
tree899b928672607b9ad74dafd42eb2bfa048a041c4 /gnu/packages/vim.scm
parent248965c91caf7d10433f090b4712a9b201968416 (diff)
parent7bc46ecc34ceb042ff890e5d306d0a2a736e891d (diff)
downloadguix-993a4fbb7c3d1f9977e0789c21905fddd72241fd.tar
guix-993a4fbb7c3d1f9977e0789c21905fddd72241fd.tar.gz
Merge remote-tracking branch 'origin/master' into wip-texlive
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 8ebdbb9a35..b1f47bd010 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -735,7 +735,7 @@ are detected, the user is notified.")))
(define-public neovim
(package
(name "neovim")
- (version "0.3.7")
+ (version "0.4.2")
(source
(origin
(method git-fetch)
@@ -745,7 +745,7 @@ are detected, the user is notified.")))
(file-name (git-file-name name version))
(sha256
(base32
- "1j6w5jvq5v7kf7diad91qs1acr427nidnk9s24yyrz0hwdd1c2lh"))))
+ "13w446plvgl219lhj29jyimhiqvs1y1byrz4qpdmxgyddmx9xqss"))))
(build-system cmake-build-system)
(arguments
`(#:modules ((srfi srfi-26)
@@ -754,13 +754,6 @@ are detected, the user is notified.")))
#:configure-flags '("-DPREFER_LUA:BOOL=YES")
#:phases
(modify-phases %standard-phases
- ;; TODO: remove 'patch-tic on update
- ;; see: https://github.com/neovim/neovim/issues/9687
- (add-after 'unpack 'patch-tic
- (lambda _
- (substitute* "src/nvim/tui/tui.c"
- (("value != NULL") "value != NULL && value != (char *)-1"))
- #t))
(add-after 'unpack 'set-lua-paths
(lambda* (#:key inputs #:allow-other-keys)
(let* ((lua-version "5.1")
@@ -774,6 +767,7 @@ are detected, the user is notified.")))
(string-append path "/?.lua;" path "/?/?.lua"))))
(lua-inputs (map (cute assoc-ref %build-inputs <>)
'("lua"
+ "lua-luv"
"lua-lpeg"
"lua-bitop"
"lua-libmpack"))))
@@ -791,6 +785,7 @@ are detected, the user is notified.")))
("jemalloc" ,jemalloc)
("libiconv" ,libiconv)
("lua" ,lua-5.1)
+ ("lua-luv" ,lua5.1-luv)
("lua-lpeg" ,lua5.1-lpeg)
("lua-bitop" ,lua5.1-bitop)
("lua-libmpack" ,lua5.1-libmpack)))