aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorng0 <ng0@no-reply.pragmatique.xyz>2017-04-15 17:46:43 +0000
committerLeo Famulari <leo@famulari.name>2017-05-10 23:59:10 -0400
commitbc84735d1434a92d64f9b6d764b2dc034246697b (patch)
tree11e613070c3ccf661f0b07dcd67ec389a3b16f8e /gnu/packages/vim.scm
parent86db4486b27389000b93e94a699fc9dafe1eba0a (diff)
downloadguix-bc84735d1434a92d64f9b6d764b2dc034246697b.tar
guix-bc84735d1434a92d64f9b6d764b2dc034246697b.tar.gz
gnu: Add neovim-syntastic.
* gnu/packages/vim.scm (neovim-syntastic): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index bb2bf3efb7..697c7dedc7 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -554,6 +554,36 @@ are detected, the user is notified.")
(home-page "https://github.com/vim-syntastic/syntastic")
(license license:wtfpl2)))
+(define-public neovim-syntastic
+ (package
+ (inherit vim-syntastic)
+ (name "neovim-syntastic")
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (vimfiles (string-append out "/share/nvim/site"))
+ (doc (string-append vimfiles "/doc"))
+ (plugin (string-append vimfiles "/plugin"))
+ (autoload (string-append vimfiles "/autoload"))
+ (syntax-checkers (string-append vimfiles "/syntax_checkers")))
+ (copy-recursively "doc" doc)
+ (copy-recursively "autoload" autoload)
+ (copy-recursively "plugin" plugin)
+ (copy-recursively "syntax_checkers" syntax-checkers)
+ #t))))))
+ (synopsis "Syntax checking plugin for Neovim")
+ (description
+ "Vim-syntastic is a syntax checking plugin for Neovim. It runs files through
+external syntax checkers and displays any resulting errors to the user. This
+can be done on demand, or automatically as files are saved. If syntax errors
+are detected, the user is notified.")))
+
(define-public neovim
(package
(name "neovim")