aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorng0 <ng0@no-reply.pragmatique.xyz>2017-04-15 17:46:42 +0000
committerLeo Famulari <leo@famulari.name>2017-05-10 23:59:10 -0400
commit86db4486b27389000b93e94a699fc9dafe1eba0a (patch)
tree0d78f988a961f86a7b0631e2a659d65be08f9bb6 /gnu/packages/vim.scm
parentcb542830a23926a3df321b37d9e2aa914ea7b8c0 (diff)
downloadguix-86db4486b27389000b93e94a699fc9dafe1eba0a.tar
guix-86db4486b27389000b93e94a699fc9dafe1eba0a.tar.gz
gnu: Add vim-syntastic.
* gnu/packages/vim.scm (vim-syntastic): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 5ceb7c8315..bb2bf3efb7 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -512,6 +512,48 @@ and powerline symbols, etc.")
(home-page "https://github.com/vim-airline/vim-airline-themes")
(license license:expat))))
+(define-public vim-syntastic
+ (package
+ (name "vim-syntastic")
+ (version "3.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/vim-syntastic/syntastic/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0wsnd9bsp5x6yiw96h1bnd1vyxdkh130hb82kyyxydgsplx92ima"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (vimfiles (string-append out "/share/vim/vimfiles"))
+ (doc (string-append vimfiles "/doc"))
+ (plugin (string-append vimfiles "/plugin"))
+ (autoload (string-append vimfiles "/autoload"))
+ (syntax-checkers (string-append vimfiles "/syntax_checkers")))
+ (copy-recursively "doc" doc)
+ (copy-recursively "autoload" autoload)
+ (copy-recursively "plugin" plugin)
+ (copy-recursively "syntax_checkers" syntax-checkers)
+ #t))))))
+ (synopsis "Syntax checking plugin for Vim")
+ (description
+ "Vim-syntastic is a syntax checking plugin for Vim. It runs files through
+external syntax checkers and displays any resulting errors to the user. This
+can be done on demand, or automatically as files are saved. If syntax errors
+are detected, the user is notified.")
+ (home-page "https://github.com/vim-syntastic/syntastic")
+ (license license:wtfpl2)))
+
(define-public neovim
(package
(name "neovim")