aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorng0 <contact.ng0@cryptolab.net>2017-02-14 13:18:21 +0000
committerKei Kebreau <kei@openmailbox.org>2017-02-28 12:25:14 -0500
commit34af179ac73e4dd01ec3b3e311db21c6ad18c90d (patch)
tree23687de58ef1b4b29e39fedaf9ca382351d7b0ec /gnu/packages/vim.scm
parent843b19ca883d32a257c2b8722f288f39721be480 (diff)
downloadguix-34af179ac73e4dd01ec3b3e311db21c6ad18c90d.tar
guix-34af179ac73e4dd01ec3b3e311db21c6ad18c90d.tar.gz
gnu: Add vim-neosnippet-snippets.
* gnu/packages/vim.scm (vim-neosnippet-snippets): New variable. Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index ee6cda04ac..a2c86e5c0a 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -200,6 +200,45 @@ features than Vim's built-in completion.")
(home-page "https://github.com/Shougo/neocomplete.vim/")
(license license:expat)))
+;; There are no release tarballs.
+(define-public vim-neosnippet-snippets
+ (let ((commit "8e2b1c0cab9ed9a832b3743dbb65e9966a64331a")
+ (revision "1"))
+ (package
+ (name "vim-neosnippet-snippets")
+ (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shougo/neosnippet-snippets")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "151wpvbj6jb9jdkbhj3b77f5sq7y328spvwfbqyj1y32rg4ifmc6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (vimfiles (string-append out "/share/vim/vimfiles")))
+ (copy-recursively "neosnippets"
+ (string-append vimfiles "/neosnippets"))
+ #t))))))
+ (synopsis "Snippets for neosnippet")
+ (description
+ "@code{neosnippet-snippets} provides standard snippets for the Vim plugin
+@code{neosnippet}. Snippets are small templates for commonly used code that
+you can fill in on the fly.")
+ (home-page "https://github.com/Shougo/neosnippet-snippets")
+ (license license:expat))))
+
(define-public vim-scheme
(let ((commit "93827987c10f2d5dc519166a761f219204926d5f")
(revision "1"))