aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-12-21 16:06:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-01-17 20:43:51 +0200
commit3161d32d37e84ad686c249cfb077126a1c9510c6 (patch)
treee68b72ce768e037d4e94881527561491aa50ae7b /gnu/packages/video.scm
parentd5650f86a7e3f16512af498bfa998398f11c3e8a (diff)
downloadguix-3161d32d37e84ad686c249cfb077126a1c9510c6.tar
guix-3161d32d37e84ad686c249cfb077126a1c9510c6.tar.gz
gnu: Add vdpauinfo.
* gnu/packages/video.scm (vdpauinfo): New variable.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index baeb747fe6..82f62a4077 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1325,3 +1325,27 @@ and JACK.")
provides an interface to video decode acceleration and presentation hardware
present in modern GPUs.")
(license (license:x11-style "file://COPYING"))))
+
+(define-public vdpauinfo
+ (package
+ (name "vdpauinfo")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://secure.freedesktop.org/~aplattner/vdpau/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1i2b0k9h8r0lnxlrkgqzmrjakgaw3f1ygqqwzx8w6676g85rcm20"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("libx11" ,libx11)))
+ (propagated-inputs
+ `(("libvdpau" ,libvdpau)))
+ (home-page "https://wiki.freedesktop.org/www/Software/VDPAU/")
+ (synopsis "Tool to query the capabilities of a VDPAU implementation")
+ (description "Vdpauinfo is a tool to query the capabilities of a VDPAU
+implementation.")
+ (license (license:x11-style "file://COPYING"))))