aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-03 10:59:03 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:56:36 +0200
commit71a77016c09f937c4aad23a6182927bf66f440c2 (patch)
treeb0af587147abaa8e9be80bc9b8c568ec3a6fc642 /gnu/packages/video.scm
parent63d18ff6b918b062521b88efbf9964bdbe8eb276 (diff)
downloadguix-71a77016c09f937c4aad23a6182927bf66f440c2.tar
guix-71a77016c09f937c4aad23a6182927bf66f440c2.tar.gz
gnu: Add mediasdk.
* gnu/packages/video.scm (mediasdk): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 77d929e1f5..940670fd52 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -172,6 +172,48 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public mediasdk
+ (package
+ (name "mediasdk")
+ (version "20.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/Intel-Media-SDK/MediaSDK.git")
+ (commit (string-append "intel-" name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0blwcxr5j8762nylx2cxrq0h53bpgnk859dbs6crq4wr9fcxlx9z"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ "-DENABLE_X11=ON"
+ "-DENABLE_X11_DRI3=ON"
+ "-DENABLE_WAYLAND=ON"
+ "-DENABLE_TEXTLOG=ON"
+ "-DENABLE_STAT=ON"
+ "-DBUILD_TESTS=ON"
+ "-DBUILD_TOOLS=ON"
+ (string-append "-DCMAKE_EXE_LINKER_FLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib"))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)))
+ (inputs
+ `(("libdrm" ,libdrm)
+ ("libva" ,libva)
+ ("pciaccess" ,libpciaccess)
+ ("wayland" ,wayland)
+ ("x11" ,libx11)))
+ (synopsis "Intel Media SDK")
+ (description "MediaSDK provides a plain C API to access hardware-accelerated
+video decode, encode and filtering on Intel's Gen graphics hardware platforms.")
+ (home-page "http://mediasdk.intel.com/")
+ (license (license:non-copyleft "file:///LICENSE"))))
+
(define-public schroedinger
(package
(name "schroedinger")