aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-08-19 01:09:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-08-19 01:10:42 +0200
commit5f524bdd0498e96c4cf69aef3edf346ccdcdc1a1 (patch)
treef755a525a78d55285202cab5aa9bde2a2540e860 /gnu/packages/video.scm
parenteb86a44254745be9bf0f1cc78636ef719c6835b3 (diff)
downloadguix-5f524bdd0498e96c4cf69aef3edf346ccdcdc1a1.tar
guix-5f524bdd0498e96c4cf69aef3edf346ccdcdc1a1.tar.gz
Revert "Revert "gnu: Add libde265.""
This reverts commit 0d792f37cdc723b593645bb871afefd699d5165b.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 9563ddf50b..80a2b3319f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -420,6 +420,44 @@ applications by providing high-level classes for commonly required tasks.")
(home-page "https://dirk-farin.net/software/libvideogfx/index.html")
(license license:lgpl2.1+)))
+(define-public libde265
+ (package
+ (name "libde265")
+ (version "1.0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/strukturag/libde265.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1qisj8ryzbknam3hk81rq70fsd9mcpxm898bqygvbsmbwyvmz3pg"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)))
+ (inputs
+ `(;; XXX: Build fails with libvideogfx.
+ ;; ("libvideogfx" ,libvideogfx)
+ ("qt" ,qtbase)
+ ("sdl" ,sdl)))
+ (synopsis "H.265 video codec implementation")
+ (description "Libde265 is an implementation of the h.265 video codec. It is
+written from scratch and has a plain C API to enable a simple integration into
+other software.")
+ (home-page "https://www.libde265.org/")
+ (license
+ (list
+ ;; Applications.
+ license:expat
+ ;; Library.
+ license:lgpl3+))))
+
(define-public tslib
(package
(name "tslib")