aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-22 21:31:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-22 21:45:29 -0400
commit5174820753be045ba4fc7cc93da33f4e0b730bc3 (patch)
treeda362d775be33f41584b615ed918dd944e23480c /gnu/packages/version-control.scm
parentcb2e7efa6c17f02c7051bcf6e0d1b8b869ebcce7 (diff)
downloadguix-5174820753be045ba4fc7cc93da33f4e0b730bc3.tar
guix-5174820753be045ba4fc7cc93da33f4e0b730bc3.tar.gz
gnu: python-pre-commit: Move deprecated variable next to replacement.
This fixes a module import dependency cycle, which was introduced in 831baaf81e57ce9d9053ba6f9e0653a2d27298c4 ("gnu: python-pre-commit: Replace with pre-commit."). The rule of thumb to avoid these is that the deprecated package should live next to the replacement package (in the same module). * gnu/packages/python-xyz.scm (python-pre-commit): Move to... * gnu/packages/version-control.scm (python-pre-commit): ... here.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 85291b12b7..2c38734ad2 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1759,6 +1759,9 @@ specify a list of hooks you want and pre-commit manages the installation and
execution of any hook written in any language before every commit.")
(license license:expat)))
+(define-public python-pre-commit
+ (deprecated-package "python-pre-commit" pre-commit))
+
(define-public mercurial
(package
(name "mercurial")