aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-10-25 15:28:15 -0400
committerLeo Famulari <leo@famulari.name>2020-10-25 15:37:38 -0400
commit375ef50ce63c5ed552973cab3619d055d7b41b99 (patch)
tree99237a92ccc8928c0794901ddc4d91c24e5941fc /gnu/packages/version-control.scm
parent13a3b9c748a80c0d4c79450e479416480273d2f7 (diff)
downloadguix-375ef50ce63c5ed552973cab3619d055d7b41b99.tar
guix-375ef50ce63c5ed552973cab3619d055d7b41b99.tar.gz
gnu: Git: Update to 2.29.1.
* gnu/packages/version-control.scm (git): Update to 2.29.1. (native-inputs)[git-manpages]: Update hash. (git-minimal)[arguments]: Delete obsolete phase 'delete-svn-test'.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 0e0e59d1a2..036c0fa09b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -159,14 +159,14 @@ as well as the classic centralized workflow.")
(define-public git
(package
(name "git")
- (version "2.28.0")
+ (version "2.29.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "17a311vzimqn1glc9d7x82rhb1mb81m5rr4g8xji8idaafid39fz"))))
+ "1cxd2h0k6bhv25avnk40h0pahgc7vgs37dc6kmln3pfhjyb6019h"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -183,7 +183,7 @@ as well as the classic centralized workflow.")
version ".tar.xz"))
(sha256
(base32
- "1dvwq0py8a2ywmgc5pzdlsj3608s7r9wyba292728fcs3yj7ynk6"))))
+ "1gn7fhh8qfgfwr0gbgzwv1wncrvhc9iic9fg9sbns44kxa59biyk"))))
;; For subtree documentation.
("asciidoc" ,asciidoc-py3)
("docbook-xsl" ,docbook-xsl)
@@ -518,11 +518,6 @@ everything from small to very large projects with speed and efficiency.")
(delete 'install-man-pages)
(delete 'install-subtree)
(delete 'install-credential-netrc)
- (add-before 'check 'delete-svn-test
- (lambda _
- ;; This test cannot run since we are not building 'git-svn'.
- (delete-file "t/t9020-remote-svn.sh")
- #t))
(add-after 'install 'remove-unusable-perl-commands
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))