aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-09 16:35:41 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-09 16:35:41 +0100
commite90e0fad1b3ba79d81f02424e143ee6f4f736e8b (patch)
tree2c26190fd9114199b0ef79303e18a61100cab4af /gnu/packages/version-control.scm
parent8ea0700d231a8819fc7e8332e9685f0ce15c174e (diff)
parent9ec2a4d3fec44f08a55df9f5f3d1a04b83e7fcf6 (diff)
downloadguix-e90e0fad1b3ba79d81f02424e143ee6f4f736e8b.tar
guix-e90e0fad1b3ba79d81f02424e143ee6f4f736e8b.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm23
1 files changed, 17 insertions, 6 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index d2ddfeef00..7f352d0b0b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -112,14 +112,14 @@ as well as the classic centralized workflow.")
(define-public git
(package
(name "git")
- (version "2.11.1")
+ (version "2.12.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "05b4jw86w77c3pyh3nm6aw31vhxwzvhnx2x0bcfqmm15wg57k9y0"))))
+ "09r0lcjj5v2apj39f0ziqzjq2bi1jpnhszc9q4n0ab86g5j7c88q"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -132,7 +132,7 @@ as well as the classic centralized workflow.")
version ".tar.xz"))
(sha256
(base32
- "0cfa3c2r7d86ksswxdl0jqdka9mai3446gg8380921gf779nwj39"))))))
+ "0ws7h04ijqr2l0pp9qbds65v9cd70v0qfpnhqncn9zqfspw5d0wb"))))))
(inputs
`(("curl" ,curl)
("expat" ,expat)
@@ -592,7 +592,7 @@ also walk each side of a merge and test those changes individually.")
(define-public gitolite
(package
(name "gitolite")
- (version "3.6.5")
+ (version "3.6.6")
(source (origin
(method url-fetch)
(uri (string-append
@@ -601,7 +601,7 @@ also walk each side of a merge and test those changes individually.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0xpqg04gyr4dhdhxx5lbk61lwwd5ml32530bigg2qy663icngwqm"))))
+ "07q33f86694s0x3k9lcmy1vzfw9appdrlmmb9j3bz4qkrxqdnwb9"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no tests
@@ -617,6 +617,17 @@ also walk each side of a merge and test those changes individually.")
(substitute* (find-files "." ".*")
((" perl -")
(string-append " " perl " -"))))))
+ (add-before 'install 'fix-hooks-shebangs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((perl (string-append (assoc-ref inputs "perl")
+ "/bin/perl")))
+ ;; The files in 'lib/Gitolite/Hooks' keep references to
+ ;; '/usr/bin/perl', without this fix it is impossible to
+ ;; to run gitolite in production.
+ (substitute* (find-files "src/lib/Gitolite/Hooks" ".*")
+ (("/usr/bin/perl")
+ perl))
+ #t)))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((output (assoc-ref outputs "out"))
@@ -1211,7 +1222,7 @@ Mercurial, Bazaar, Darcs, CVS, Fossil, and Veracity.")
`(;; for the tests
("python2-six" ,python2-six)))
(propagated-inputs
- `(("python2-dateutil" ,python2-dateutil-2)
+ `(("python2-dateutil" ,python2-dateutil)
("python2-futures" ,python2-futures)
("python2-rauth" ,python2-rauth)
("python2-swiftclient" ,python2-swiftclient)))