aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-10 10:04:29 +0000
committerLeo Famulari <leo@famulari.name>2016-08-12 14:11:51 -0400
commitb3885778e8e438e8526a8ee9e96072fd00f5cae5 (patch)
tree8d2d35e30286803c65c0f2da153d5bd5ea61e192 /gnu/packages/version-control.scm
parentb227f0be8931831a574966c9a69667e81debb580 (diff)
downloadguix-b3885778e8e438e8526a8ee9e96072fd00f5cae5.tar
guix-b3885778e8e438e8526a8ee9e96072fd00f5cae5.tar.gz
gnu: Add stagit.
* gnu/packages/version-control.scm (stagit): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm35
1 files changed, 33 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 767715d1b1..f7167088ca 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,8 +28,8 @@
(define-module (gnu packages version-control)
#:use-module ((guix licenses)
- #:select (asl2.0 bsd-2 bsd-3
- gpl1+ gpl2 gpl2+ gpl3+ lgpl2.1
+ #:select (asl2.0 bsd-2 bsd-3 expat
+ gpl1+ gpl2 gpl2+ gpl3+ isc lgpl2.1
public-domain x11-style))
#:use-module (guix utils)
#:use-module (guix packages)
@@ -1250,3 +1251,33 @@ access and administration over HTTP CGI or via a built-in HTTP server. It has
a built-in wiki, built-in file browsing, built-in tickets system, etc.")
(license (list public-domain ;src/miniz.c, src/shell.c
bsd-2))))
+
+(define-public stagit
+ (package
+ (name "stagit")
+ (version "0.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://dl.2f30.org/releases/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0z5r06wqrfnsz24ci4hjqbd62svclvhkgzaq9npsyjcp6jnf7izc"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure
+ (inputs
+ `(("libgit2" ,libgit2)))
+ (home-page "http://2f30.org")
+ (synopsis "Static Git web page generator")
+ (description "Stagit creates static web pages for Git repositories. The
+results can be served with an HTTP server.")
+ ;; The source code distribution is Expat-licensed, but the source files
+ ;; 'reallocarray.c', 'strlcat.c', and 'strlcpy.c' are released under the ISC
+ ;; license.
+ (license (list expat isc))))