aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 03:49:44 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:43:41 -0400
commit6d0f26123780f665f03e70a5f29d1e3e71b4d2cb (patch)
tree1a8c5bfc01323423592f032e2a82957208a68e2c /gnu/packages/version-control.scm
parent2c48ed4e97fe9ed645d9832b0a7735581e959511 (diff)
downloadguix-6d0f26123780f665f03e70a5f29d1e3e71b4d2cb.tar
guix-6d0f26123780f665f03e70a5f29d1e3e71b4d2cb.tar.gz
gnu: subversion: Use invoke.
* gnu/packages/version-control.scm (subversion)[arguments]: Use invoke and remove vestigial plumbing in the 'install-perl-bindings' phase.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm32
1 files changed, 15 insertions, 17 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 36dbce4688..4aac1fc2fb 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1106,23 +1106,21 @@ following features:
(lambda* (#:key outputs #:allow-other-keys)
;; Follow the instructions from 'subversion/bindings/swig/INSTALL'.
(let ((out (assoc-ref outputs "out")))
- (and (zero? (system* "make" "swig-pl-lib"))
- ;; FIXME: Test failures.
- ;; (zero? (system* "make" "check-swig-pl"))
- (zero? (system* "make" "install-swig-pl-lib"))
-
- ;; Set the right installation prefix.
- (with-directory-excursion
- "subversion/bindings/swig/perl/native"
- (and (zero?
- (system* "perl" "Makefile.PL"
- "NO_PERLLOCAL=1"
- (string-append "PREFIX=" out)))
- (zero?
- (system* "make" "install"
- (string-append "OTHERLDFLAGS="
- "-Wl,-rpath="
- out "/lib"))))))))))))
+ (invoke "make" "swig-pl-lib")
+ ;; FIXME: Test failures.
+ ;; (invoke "make" "check-swig-pl")
+ (invoke "make" "install-swig-pl-lib")
+
+ ;; Set the right installation prefix.
+ (with-directory-excursion
+ "subversion/bindings/swig/perl/native"
+ (invoke "perl" "Makefile.PL"
+ "NO_PERLLOCAL=1"
+ (string-append "PREFIX=" out))
+ (invoke "make" "install"
+ (string-append "OTHERLDFLAGS="
+ "-Wl,-rpath="
+ out "/lib")))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
;; For the Perl bindings.