aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-09-10 18:39:28 -0400
committerLeo Famulari <leo@famulari.name>2018-09-10 19:02:45 -0400
commit5d9c28f117fa6fa9d0b4439ac02e74a4656d25af (patch)
tree424409f5be839f05d3b6251b840c53c7020ece48 /gnu/packages/version-control.scm
parent2225d56a14a2d8d29374a14eefe90b3cffa79804 (diff)
downloadguix-5d9c28f117fa6fa9d0b4439ac02e74a4656d25af.tar
guix-5d9c28f117fa6fa9d0b4439ac02e74a4656d25af.tar.gz
gnu: git: Update to 2.19.0.
* gnu/packages/version-control.scm (git): Update to 2.19.0. (cgit)[inputs]: Use the source of Git 2.18.0.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 5e0b497ace..3774961786 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -146,14 +146,14 @@ as well as the classic centralized workflow.")
(name "git")
;; XXX When updating Git, check if the special 'git-source' input to cgit
;; needs to be updated as well.
- (version "2.18.0")
+ (version "2.19.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "14hfwfkrci829a9316hnvkglnqqw1p03cw9k56p4fcb078wbwh4b"))))
+ "1x1y5z3awabmfg7hk6zb331jxngad4nal4507v96bnf0izsyy3qq"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -166,7 +166,7 @@ as well as the classic centralized workflow.")
version ".tar.xz"))
(sha256
(base32
- "15k04s9pcc5wkmlfa8x99nbgczjbx0c91767ciqmjy9kwsavxqws"))))))
+ "1jvxiqvp9q4is3np063ny7rnmk5hm36d34bhi3cgv89njqdh8laf"))))))
(inputs
`(("curl" ,curl)
("expat" ,expat)
@@ -642,7 +642,14 @@ collaboration using typical untrusted file hosts or services.")
("xz" ,xz)))
(inputs
`(;; Building cgit requires a Git source tree.
- ("git-source" ,(package-source git))
+ ("git-source"
+ ,(origin
+ (method url-fetch)
+ ;; XXX CGit is currently incompatible with Git > 2.18.
+ (uri "mirror://kernel.org/software/scm/git/git-2.18.0.tar.xz")
+ (sha256
+ (base32
+ "14hfwfkrci829a9316hnvkglnqqw1p03cw9k56p4fcb078wbwh4b"))))
("openssl" ,openssl)
("groff" ,groff)
("python" ,python)