aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-11-29 23:05:54 +0100
committerLudovic Courtès <ludo@gnu.org>2017-11-29 23:40:39 +0100
commit53d26163c6ec1a1c48a1ec775e67b739b9005270 (patch)
tree7d59c82f5e544dcf89d9bdad5da8a4f912df0d61 /gnu/packages/version-control.scm
parent6ee797f326274284ac60dad50688f877a93711d2 (diff)
downloadguix-53d26163c6ec1a1c48a1ec775e67b739b9005270.tar
guix-53d26163c6ec1a1c48a1ec775e67b739b9005270.tar.gz
gnu: libgit2: Avoid dependency on cURL.
This reduces the closure size from 225 MiB to 80 MiB, while still supporting HTTP(S) access. * gnu/packages/version-control.scm (libgit2)[source](modules, snippet): New fields. [inputs]: Remove CURL; add HTTP-PARSER.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 9de660f090..21ea90be72 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -370,7 +370,11 @@ everything from small to very large projects with speed and efficiency.")
(sha256
(base32
"1b3figbhp5l83vd37vq6j2narrq4yl9pfw6mw0px0dzb1hz3jqka"))
- (patches (search-patches "libgit2-0.25.1-mtime-0.patch"))))
+ (patches (search-patches "libgit2-0.25.1-mtime-0.patch"))
+
+ ;; Remove bundled software.
+ (snippet '(delete-file-recursively "deps"))
+ (modules '((guix build utils)))))
(build-system cmake-build-system)
(outputs '("out" "debug"))
(arguments
@@ -390,7 +394,7 @@ everything from small to very large projects with speed and efficiency.")
(lambda _ (zero? (system* "./libgit2_clar" "-v" "-Q")))))))
(inputs
`(("libssh2" ,libssh2)
- ("libcurl" ,curl)
+ ("http-parser" ,http-parser)
("python" ,python-wrapper)))
(native-inputs
`(("pkg-config" ,pkg-config)))